Can't run drivers for RTX 3060 (laptop) (Ubuntu 20.04)

Hello! I’ve been using Ubuntu 20.04 alongside ROS Noetic for my course in my previous laptop which had an AMD CPU with an iGPU, so never really had to struggle with drivers. I had to get a new laptop (ASUS TUF Gaming F15 2022) which has an Intel i7-12700H and an RTX 3060. The 12th gen processor (as far as I know) means I had to install a newer kernel (which was a hassle by itself because the laptop wouldn’t boot to GUI (or not at all in some cases, had to do a minimal install with no updates and no extra drivers/proprietary software and unplug the ethernet cable during the whole process)).

I ended up using mainline to install the 5.16.20 kernel via the Ctrl + Alt + F2 CLI, but it still didn’t boot into GUI until I sudo apt installed the nvidia drivers 470. Seeing that this worked I would have thought that the NVIDIA GPU was the one rendering the desktop, but when I run nvidia-smi it outputs the “not installed or not running” error.

**aaron@lap-aarongrt:~$** sudo lshw -C display
[sudo] password for aaron: 
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: iomemory:600-5ff iomemory:620-61f memory:5f000000-5fffffff memory:6000000000-61ffffffff memory:6200000000-6201ffffff ioport:3000(size=128) memory:60000000-6007ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: iomemory:620-61f iomemory:400-3ff memory:622e000000-622effffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

**aaron@lap-aarongrt:~$** nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:6371): GLib-GObject-CRITICAL **: 18:28:45.665: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 18:28:45.667: PRIME: No offloading required. Abort
** Message: 18:28:45.667: PRIME: is it supported? no

I spent the whole yesterday trying out solutions, including the prime-select nvidia one and a bunch more.
I’ll be including the output file incase it’s of use to you guys. If you have any clue of what’s going on please let me know!


Aarón RT

Edit: I disabled Secure Boot and Fast Boot and am running Dual Boot with Windows11

nvidia-bug-report.log.gz (81.0 KB)

You have an incompatible kernel from mainline installed, please return to the stock 5.13 kernel.

Please forget what I said, I posted to the wrong thread.
In your case, please upgrade the kernel using the liquorix ppa and install a new firmware package manuallly

1 Like

I installed the liquorix kernel following the instructions on your page, rebooted and ran them. nvidia-smi works now! I then installed the firmware, though I can’t see any changes, should I leave them?

The updated firmware contains fixes for your 12th gen intel gpu, so this is needed for proper function.

1 Like

I see. Thanks a lot!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.