Cant set python3.6 as default / Cant install python 3.6.15

Hello.I have python3.7 and python3.6 in my system.I want to set python3.6 as default and i cant.I tried to:
1.sudo update-alternatives --set python /usr/bin/python3.6 (error: no alternatives for python3)
2.sudo update-alternatives —install /usr/bin/python python /usr/bin/python3.7 1
sudo update-alternatives —install /usr/bin/python python /usr/bin/python3.6 2
(I could set python3.6 as 2, but couldnt do that for python3.7; system doesnt see it.As a result i still have python 3.7 as default)
3. * gedit ~/.bashrc
alias python=python3.6
(I also tried to add this line in the ~/.bashrc file by gedit command, but it didnt do anything)
4.Finally i followed the instructions:
$ sudo rm /usr/bin/python3
$ sudo ln -s /usr/bin/python3.6 /usr/bin/python3
And as a result i get the error (when i tried to run python): /usr/local/bin/python3.6: No such file or directory.And now i cant even launch the terminal.I used backup to fix that.

(Also , I tried to install python 3.6.15 by command “sudo apt-get install python3.6.15”, but i couldnt.)
I have 2 questions:

  1. How can i install python 3.6.15?
    2.How can i set python 3.6 as default ?


What kind of error do you get when running the sudo apt-get install python3.6.15?


Thansk for your reply.
I got this error:


Could you follow the below link to build it from the source?


Hi.Thanks for your reply, but unfortunatelly it didnt help.I followed the instruction, but i couldnt complete this step : sudo make altinstall.Process was running for 1-2 hours and as a result it destroyed my sd card (please check the first picture below) .I dont know what happend, but i saw little text display with square boxes, insted of the text before the black screen and i didnt do anything with that.

After this i couldnt launch jetson nano anymore:

I will use backup to fix that, but i still need python 3.6.15 and I have 3 questions.

1.What did i do wrong and how can i install python3.6.15 this way :
python 3.6 - How to install python3.6 on Ubuntu 22.04 - Stack Overflow ?

( i executed command:
“make -j 4 # adjust for number of your CPU cores”
instead of “make -j 8 # adjust for number of your CPU cores”,
because i have only 4 cpu cores in my jetson P3450.Maybe my problem is associated with that?)

2.Python 3.6.15 is the last version of python 3.6, so can i just update my python from 3.6.9 to 3.6.15 ( i have python 3.6.9 on my jetson nano)?If so, how can i do that ?

3.Or is there any other way to install python 3.6.15 ?


Could you share which patch you need from Python 3.6.15?
Since the default Python 3.6.9 seems to provide similar functionality.


Hi.My problem is associated with a specific version of the opencv { you can check this:
Import error.Module not found error cv2.No module named cv2.Cant install open cv}
I installed all necessary components in the anaconda venv (with python 3.6.15) and now i just want to repeat all my steps in the main environment, because i cant import python-inference in the venv.


Suppose you should be able to get python 3.6.15 by building from the source.

If you keep meeting issues when doing so, please contact the Python team for help.
They should know better about how to install Python 3.6.15 on aarch64 environment.