Can't setting breakpoints in .cu-file

Hi!

I can’t setting breakpoints in .cu-file. I compiled the .cu in emulation mode (I set the -deviceemu flag in file.cu->Properties->Costum Build Step->Commandline: nvcc -c -deviceemu –o $(ConfigurationName)\cuda.obj cuda.cu). And I think that works, the compiler defines DEVICE_EMULATION.

What did I wrong?

Thank you for your help.

In my .cu-file there is a host function and a global function. I can’t set breakpoints in both of them.

Please help me :wacko: !

Now, I have take the template from the sdk. Setting breakpoints works fine. I think the template project is the best start up for cuda beginners. :thumbup:

I believe you have to add -g (or -G) to nvcc’s arguments for it to build wth debug information.

Yes, you are right! -g was missing. Thank you very much!