Can't start isaac ros yolov8 with Quickstart manual

Hi,

I proceeded with the installation according to the manual, but a problem occurred.
the Quickstart manual for ROS object detection

A problem occurred while executing procedure #7 and #8.
#7. Run the following launch file to perform YOLOv8 detection using TensorRT”
#8. Run the image publisher node to publish input images for inference. A sample image”

There is no error, but there is no response.
I have attached a screenshot to help you understand.

Plus, the Detectnet Implement worked well. So, I think it is not a environment setup problem.


Please regard this problem.

Hi @pmchelp512

welcome here. To better help you, which Jetpack have you installed on your Jetson?

Hi,

I installed and tested it on my workstation without Jetson devices.

2024년 3월 9일 (토) 오후 7:37, Raffaello Bonghi via NVIDIA Developer Forums <notifications@nvidia.discoursemail.com>님이 작성:

I tried to install the quick start manual many times.
yolov8s.onnx, yolov8s.plan, yolov8s.pt are placed in the tmp folder.

When I implement this commend below.
cd /workspaces/isaac_ros-dev &&
ros2 launch isaac_ros_yolov8 isaac_ros_yolov8_visualize.launch.py model_file_path:=/tmp/yolov8s.onnx engine_file_path:=/tmp/yolov8s.plan input_binding_names:=[‘images’] output_binding_names:=[‘output0’] network_image_width:=640 network_image_height:=640 force_engine_update:=False image_mean:=[0.0,0.0,0.0] image_stddev:=[1.0,1.0,1.0] input_image_width:=640 input_image_height:=640 confidence_threshold:=0.25 nms_threshold:=0.45

I will get the following result. please check the attached screen shot.


Hi @pmchelp512

Based on your screenshot, the YOLO conversion is still in progress. Please wait, as this process can take some time.

WARN /home/jenkins/agent/workspace/ly_debian-compatible-release-2.1/isaac_ros-dev/ros_ws/src/isaac_ros_dnn_inference/isaac_ros_tensor_rt/gxf/tensor_rt/tensor_rt_inference.cpp@278: Rebuilding CUDA engine /tmp/yolov8s.plan (forced by config). Note: this process may take up to several minutes.