Cant startx on new tty

Ubuntu 16.04, NVIDIA Driver Version: 375.66.
Everything works fine on ctrl+alt+f7, but when I try to use other tty, for example, tty1 and “startx – :1” (logs are usual), I get black screen. If I switch to intel, it works fine. Tried to use nvidia-xconfig, but it didnt help.
Thanks for any help.
nvidia-bug-report.log.gz (142 KB)

Can you please run nvidia-bug-report.sh and attach the resulting nvidia-bug-report.log.gz after you tried to start the second X server?

Does it happen to be a laptop with Optimus?
Read this then: https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia

Attached to the first message. Hope it will help.

Read the link I provided, generate a ~/.xinitrc as mentioned there.
Should work then.

I tried, but it doesn’t help. However, there is no black screen, but “connection to server was lost”. And log doesn’t show any errors.
Xorg.1.log (40.7 KB)

The XServer closes when there’s no client connected. Try adding

xterm &

at the end of your xinitrc

Added. Same situation.

Sorry, should be

exec xterm

instead of

xterm &

Oh. I tried it, it opened white terminal on black screen, and when I called nautilus, it became normal!

generix, Thank you very much!