Can't switch to RTX 3050 TI on my laptop - RmInitAdapter failed! (0x24:0x72:1556)

Hi, I’m running Ubuntu 22.04 on a Dell XPS 15 9520, which has both Intel integrated GPU and RTX 3050 TI and I’m trying to switch to the RTX.

I can’t figure out what’s wrong - when doing lshw -C display it detects both cards and RTX using nvidia driver:

*-display                 
     description: 3D controller
     product: GA107M [GeForce RTX 3050 Ti Mobile]
     vendor: NVIDIA Corporation
     physical id: 0
     bus info: pci@0000:01:00.0
     logical name: /dev/fb0
     version: a1
     width: 64 bits
     clock: 33MHz
     capabilities: pm msi pciexpress bus_master cap_list rom fb
     configuration: depth=32 driver=nvidia latency=0 mode=3456x2160 visual=truecolor xres=3456 yres=2160
     resources: iomemory:600-5ff iomemory:610-60f irq:16 memory:be000000-beffffff memory:6000000000-60ffffffff memory:6100000000-6101ffffff ioport:3000(size=128)
*-display
     description: VGA compatible controller
     product: Alder Lake-P Integrated Graphics Controller
     vendor: Intel Corporation
     physical id: 2
     bus info: pci@0000:00:02.0
     logical name: /dev/fb0
     version: 0c
     width: 64 bits
     clock: 33MHz
     capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
     configuration: depth=32 driver=i915 latency=0 resolution=3456,2160
     resources: iomemory:610-60f iomemory:400-3ff irq:185 memory:6188000000-6188ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

but nvidia-smi says “No devices were found.” and it’s using the integrated GPU even when switching to performance mode in nvidia-settings (and rebooting ofc)

I tried different driver versions (always purging and restarting before changing) 535, 535-open, 545 and now 550 and none worked. I updated my BIOS too. Secure Boot is disabled.

nvidia-settings doesn’t have any gpu specific settings, I can basically just set on demand / always on. When running it I get this error in the console:

ERROR: A supplied argument is invalid

(nvidia-settings:35448): GLib-GObject-CRITICAL **: 10:36:54.502: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:35448): CRITICAL **: 10:36:54.503: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

ERROR: nvidia-settings could not find the registry key file or the X server is
       not accessible. This file should have been installed along with this
       driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

Any help would be greatly appreciated
nvidia-bug-report.log (2.9 MB)

The gpu might be broken. Please check if it works in Windows.

thanks for such a quick response!
So you’re suspecting it’s a hardware issue, can you elaborate why you think that? Anything specific in the logs maybe? I only have ubuntu installed so it’s not straightforward to just try in Windows atm

It’s rather that there’s nothing specific in the logs but the rminit failed error. Failure without other possible reasons point to defective hardware.