Can't use my egpu

Hi, my laptop has RTX 2060. “Create” works fine with it. But when I plug in my egpu with RTX 3080 and open “Create”, it gives me this message:

“RTX engine creation failed. RTX renderers in viewport will be disabled. Please make sure selected GPU is RTX-capable, and GPU drivers meet requirements”.

Can you help me please?

Hi @zack_saimon! Welcome to the Community! I have alerted the dev team about your issue. Thanks for reaching out to us!

Hi @zack_saimon! The development team would like to see your full log report. You can grab the log file here: C:\Users\<USERNAME>\.nvidia-omniverse\logs

Also, which eGPU are you using?

kit_20211006_132954.log (382.0 KB)


hello @zack_saimon

Can I request some more information?
Can you do two tests for me. Want to see if any of these tests result in Create working with your eGPU attached.

Get a Windows command prompt at the location of the desired Create version to be run. This location can be found by using the Launcher.

  • Go to Launcher “Library” tab
  • Select “Create” on the left pane
  • Click on the hamburger icon and scroll down to “settings” and select
  • Choose the version of Create and click on the “folder” icon OR get path from dialog
  • Will show you path to folder that we want to get command prompt at

At the command prompt run

omni.create.singlegpu.bat --/renderer/activeGpu=<Number, 0…N>
Where activeGpu is the GPU instance to use

In your case there are the two tests

omni.create.singlegpu.bat --/renderer/activeGpu=0

And then

omni.create.singlegpu.bat --/renderer/activeGpu=1

The first test will only use your laptop GPU
Second will only use the eGPU

Please tell me if any of these results in a viable Create.
Can you collect after each test?

Create works fine in both tests!

@zack_saimon - Thank you very much. Test was to see if multi-GPU related vs eGPU. Seems to be in the multi-GPU area. Will continue to look into this.

Not that i expect anything, but assume when you now start Create from Launcher (which will use all GPUs) it still fails?


hello @zack_saimon
Your problem is in the area of multiple GPUs. I have created a case for development to investigate. At the moment i do not have a workaround that would allow you to use both GPUs at the same time. My steps above will allow you to use one or the other.

I have communicated the logs and debug that you have provided. Once the problem has been identified and a release issued will respond to this post