CarmaKit drivers issue

I am trying to use 12.3 dual-VGA TFT-LCD module LQ123K1LG03 as my display to Carma Kit via LVDS interface. Please review the Xorg.0.log and let us know if the LCD is supported by nvidia driver.

Nvidia driver version 302.10.

Or am I missing something in my configuration?

The issue is X is not running and it fails to detect the LCD connected.
Please send the updated Nvidia Drivers for carma Kit or let us know any workaround.

Your help in this is greatly appreciated.

I couldnot attach Xorg.0.log…so am pasting the content here:

[ 4567.736]
X.Org X Server 1.10.1
Release Date: 2011-04-15
[ 4567.736] X Protocol Version 11, Revision 0
[ 4567.736] Build Operating System: Linux 2.6.35-22-omap armv7l Ubuntu
[ 4567.736] Current Operating System: Linux carma-devkit 3.1.10-carma #2 SMP PREEMPT Fri Aug 31 15:28:42 PDT 2012 armv7l
[ 4567.736] Kernel command line: console=ttyS0,115200n8 console=tty1 lp0_vec=0x00002000@0x9C406000 video=tegrafb vmalloc=256M mem=2047M@2048M noinitrd usbcore.old_scheme_first=1 core_edp_mv=1300 panel=lvds tegraid=30.1.2.0.0 debug_uartport=lsport,2 smp tegra_fbmem=3072K@0xBFE00000 max_cpu_cur_ma=10000 root=/dev/mmcblk0p1 rw rootwait gpt
[ 4567.736] Build Date: 19 April 2011 03:43:47PM
[ 4567.736] xorg-server 2:1.10.1-1ubuntu1 (For technical support please see http://www.ubuntu.com/support)
[ 4567.736] Current version of pixman: 0.20.2
[ 4567.736] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 4567.736] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 4567.737] (==) Log file: “/var/log/Xorg.0.log”, Time: Sun Jan 2 22:14:10 2000
[ 4567.737] (==) Using config file: “/etc/X11/xorg.conf”
[ 4567.737] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 4567.738] (==) ServerLayout “DualView”
[ 4567.739] (
) |–>Screen “Screen 1” (0)
[ 4567.739] () | |–>Monitor “HDMI-1”
[ 4567.739] (
) | |–>Device “Tegra”
[ 4567.739] () |–>Input Device “Keyboard0”
[ 4567.739] (
) |–>Input Device “Mouse0”
[ 4567.739] () Option “BlankTime” “0”
[ 4567.739] (
) Option “StandbyTime” “0”
[ 4567.739] () Option “SuspendTime” “0”
[ 4567.739] (
) Option “OffTime” “0”
[ 4567.739] (**) Option “Xinerama” “0”
[ 4567.740] (==) Automatically adding devices
[ 4567.740] (==) Automatically enabling devices
[ 4567.740] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 4567.740] Entry deleted from font path.
[ 4567.740] (WW) The directory “/usr/share/fonts/X11/100dpi/” does not exist.
[ 4567.740] Entry deleted from font path.
[ 4567.740] (WW) The directory “/usr/share/fonts/X11/75dpi/” does not exist.
[ 4567.740] Entry deleted from font path.
[ 4567.740] (WW) The directory “/usr/share/fonts/X11/Type1” does not exist.
[ 4567.740] Entry deleted from font path.
[ 4567.740] (WW) The directory “/usr/share/fonts/X11/100dpi” does not exist.
[ 4567.740] Entry deleted from font path.
[ 4567.740] (WW) The directory “/usr/share/fonts/X11/75dpi” does not exist.
[ 4567.740] Entry deleted from font path.
[ 4567.740] (WW) `fonts.dir’ not found (or not valid) in “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”.
[ 4567.740] Entry deleted from font path.
[ 4567.741] (Run ‘mkfontdir’ on “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”).
[ 4567.741] (==) FontPath set to:
/usr/share/fonts/X11/misc,
built-ins
[ 4567.741] (==) ModulePath set to “/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules”
[ 4567.741] (WW) Hotplugging is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.
[ 4567.741] (WW) Disabling Keyboard0
[ 4567.741] (WW) Disabling Mouse0
[ 4567.741] (II) Loader magic: 0x142158
[ 4567.741] (II) Module ABI versions:
[ 4567.741] X.Org ANSI C Emulation: 0.4
[ 4567.741] X.Org Video Driver: 10.0
[ 4567.741] X.Org XInput driver : 12.3
[ 4567.741] X.Org Server Extension : 5.0
[ 4567.742] (–) PCI:*(0:1:0:0) 10de:0dfa:10de:0853 rev 161, Mem @ 0x11000000/16777216, 0x20000000/134217728, 0x28000000/33554432, I/O @ 0x10001000/128, BIOS @ 0x???/524288
[ 4567.742] (WW) “dri” will not be loaded unless you’ve specified it to be loaded elsewhere.
[ 4567.742] (WW) “dri2” will not be loaded unless you’ve specified it to be loaded elsewhere.
[ 4567.742] (II) “extmod” will be loaded. This was enabled by default and also specified in the config file.
[ 4567.742] (II) “dbe” will be loaded by default.
[ 4567.742] (II) “glx” will be loaded. This was enabled by default and also specified in the config file.
[ 4567.743] (II) “record” will be loaded by default.
[ 4567.743] (II) “dri” will be loaded even though the default is to disable it.
[ 4567.743] (II) “dri2” will be loaded even though the default is to disable it.
[ 4567.743] (II) LoadModule: “extmod”
[ 4567.745] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 4567.746] (II) Module extmod: vendor=“X.Org Foundation”
[ 4567.746] compiled for 1.10.1, module version = 1.0.0
[ 4567.746] Module class: X.Org Server Extension
[ 4567.746] ABI class: X.Org Server Extension, version 5.0
[ 4567.746] (II) Loading extension MIT-SCREEN-SAVER
[ 4567.746] (II) Loading extension XFree86-VidModeExtension
[ 4567.746] (II) Loading extension DPMS
[ 4567.746] (II) Loading extension XVideo
[ 4567.746] (II) Loading extension XVideo-MotionCompensation
[ 4567.746] (II) Loading extension X-Resource
[ 4567.746] (II) LoadModule: “glx”
[ 4567.748] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 4567.794] (II) Module glx: vendor=“NVIDIA Corporation”
[ 4567.794] compiled for 4.0.2, module version = 1.0.0
[ 4567.794] Module class: X.Org Server Extension
[ 4567.794] (II) NVIDIA GLX Module 302.26 Release Build (r302_00) (buildmeister@swio-display-x86-rhel47-09.nvidia.com) Mon Aug 6 18:13:59 PDT 2012
[ 4567.794] (II) Loading extension GLX
[ 4567.794] (II) LoadModule: “dbe”
[ 4567.797] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 4567.797] (II) Module dbe: vendor=“X.Org Foundation”
[ 4567.797] compiled for 1.10.1, module version = 1.0.0
[ 4567.797] Module class: X.Org Server Extension
[ 4567.797] ABI class: X.Org Server Extension, version 5.0
[ 4567.797] (II) Loading extension DOUBLE-BUFFER
[ 4567.797] (II) LoadModule: “record”
[ 4567.800] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 4567.800] (II) Module record: vendor=“X.Org Foundation”
[ 4567.800] compiled for 1.10.1, module version = 1.13.0
[ 4567.800] Module class: X.Org Server Extension
[ 4567.800] ABI class: X.Org Server Extension, version 5.0
[ 4567.800] (II) Loading extension RECORD
[ 4567.800] (II) LoadModule: “nvidia”
[ 4567.802] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 4567.804] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 4567.804] compiled for 4.0.2, module version = 1.0.0
[ 4567.804] Module class: X.Org Video Driver
[ 4567.804] (II) NVIDIA dlloader X Driver 302.26 Release Build (r302_00) (buildmeister@swio-display-x86-rhel47-09.nvidia.com) Mon Aug 6 17:42:48 PDT 2012
[ 4567.804] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 4567.804] (–) using VT number 7

[ 4567.815] (II) Loading sub module “fb”
[ 4567.815] (II) LoadModule: “fb”
[ 4567.817] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 4567.817] (II) Module fb: vendor=“X.Org Foundation”
[ 4567.817] compiled for 1.10.1, module version = 1.0.0
[ 4567.817] ABI class: X.Org ANSI C Emulation, version 0.4
[ 4567.817] (II) Loading sub module “wfb”
[ 4567.817] (II) LoadModule: “wfb”
[ 4567.818] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 4567.819] (II) Module wfb: vendor=“X.Org Foundation”
[ 4567.819] compiled for 1.10.1, module version = 1.0.0
[ 4567.819] ABI class: X.Org ANSI C Emulation, version 0.4
[ 4567.819] (II) Loading sub module “ramdac”
[ 4567.819] (II) LoadModule: “ramdac”
[ 4567.819] (II) Module “ramdac” already built-in
[ 4567.819] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 4567.819] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 4567.820] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 4567.820] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 4567.820] () NVIDIA(0): Depth 24, (–) framebuffer bpp 32
[ 4567.820] (==) NVIDIA(0): RGB weight 888
[ 4567.820] (==) NVIDIA(0): Default visual is TrueColor
[ 4567.820] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 4567.821] (
) NVIDIA(0): Option “TwinViewXineramaInfoOrder” “DFP-0”
[ 4567.821] () NVIDIA(0): Option “MetaModes” “DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1280+0”
[ 4567.821] (
) NVIDIA(0): Enabling 2D acceleration
[ 4568.651] (II) NVIDIA(0): NVIDIA GPU Quadro 1000M (GF108GL) at PCI:1:0:0 (GPU-0)
[ 4568.651] (–) NVIDIA(0): Memory: 2097152 kBytes
[ 4568.651] (–) NVIDIA(0): VideoBIOS: 70.08.95.00.07
[ 4568.651] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 4568.651] (–) NVIDIA(0): Interlaced video modes are supported on this GPU
[ 4568.653] (–) NVIDIA(0): Valid display device(s) on Quadro 1000M at PCI:1:0:0
[ 4568.653] (–) NVIDIA(0): DFP-0
[ 4568.653] (–) NVIDIA(0): DFP-1
[ 4568.653] (–) NVIDIA(0): DFP-0: 165.0 MHz maximum pixel clock
[ 4568.653] (–) NVIDIA(0): DFP-0: Internal Single Link TMDS
[ 4568.653] (–) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[ 4568.653] (–) NVIDIA(0): DFP-1: Internal Single Link TMDS
[ 4568.654] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0
[ 4568.656] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 4568.690] (II) UnloadModule: “nvidia”
[ 4568.690] (II) Unloading nvidia
[ 4568.690] (II) UnloadModule: “wfb”
[ 4568.690] (II) Unloading wfb
[ 4568.690] (II) UnloadModule: “fb”
[ 4568.690] (II) Unloading fb
[ 4568.690] (EE) Screen(s) found, but none have a usable configuration.
[ 4568.690]
Fatal server error:
[ 4568.690] no screens found
[ 4568.690]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 4568.690] Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 4568.690]
[ 4568.709] ddxSigGiveUp: Closing log

Please let me know if there any updated Nvidia drivers for Carma Kit to detect the LCD module attached or any workaround to resolve the issue.

Thanks and Regards,
Sravan

LQ123K1LG03 (LD-19201A) NEW_201102165787_.pdf (1.14 MB)

We purchased SECOCQ7-pITX-Xboard and Carma kit for our application.
Kernel Version: 3.1.10
Ubuntu 12.04 target filesystem
tegra_drv_abi11.so

Aggregate resolution supported for PICO ITX kit and Carma Kit in extended mode(LVDS+HDMI) is 20482048 but as we need 2560480 as aggregate resolution.
In this regard please provide possible solution to extend the resolution to 2560480 as soon as possible or latest tegra drivers which would support 2560480 in extended mode(LVDS+HDMI).

thanks and regards,
Sravan