Carter Robot not showing in Environment

Hello, when i run the random walk command or navigation with joystick command of carter robot as mentioned in Isaac Simulation documentation then Unreal Engine starts and when i press the play button, there is no robot in the environment. I can only move in environment with joystick but there is not robot to control. Can anyone please help?

Abdullah Yasir

Hi Abdullah,

Are you running the Isaac SDK app at the same time?
Carter will not appear until you run the Isaac SDK app.

Hope this helps,

Hi Liila,

Thanks for replying. How can i run the Isaac SDK app? I have run these two commands as mentioned in Documentation.

bazel run apps/carter_sim:carter_sim_joystick – --config=“apps/asset/maps/carter_warehouse_p.config.json” --graph=“apps/assets/maps/carter_warehouse_p.graph.json”

./Engine/Binaries/Linux/UE4Editor IsaacSimProject CarterWarehouse_P -vulkan-isaac_sim_config_json=“FULL_PATH_TO/apps/carter_sim/bridge_config/carter_full.json”

What else do i need to do?

Abdullah Yasir (This is my colleague’s account)

Change FULL_PATH_TO on full path to your Isaac SDK. For example, my Isaac SDK is located in the /home/user/isaac, and Isaac Sim is in /home/user/UnrealEngine and I use the combined command to run both applications:

cd ~/UnrealEngine \
./Engine/Binaries/Linux/UE4Editor IsaacSimProject CarterWarehouse_P -vulkan -isaac_sim_config_json="/home/user/isaac/apps/carter_sim/bridge_config/carter_full.json" & \
cd ~/isaac \
bazel run apps/carter_sim:carter_sim -- --config="apps/assets/maps/carter_warehouse_p.config.json" --graph="apps/assets/maps/carter_warehouse_p.graph.json"

THanks a lot Sergey!
Yes, please make sure you have changed the full path of the config files.

If everything runs, you should see that the sim and SDK are connected.


Thanks a lot Sergey and Liila