Carter V1 robot camera shaking too much while rotating via cmd_vel topic in Hospital usd environment

Please download the video by right click , as its showing “no video with supported format”.

The entire robot may be shaking due to a collision calculation error in the physics engine. Collision calculation with trimesh collider is unstable. Collider type of the Hospital environment’s floor is trimesh. Consider removing the colliders of the floor assets or changing the collider type to bounding box.

Thanks for your response , as i am not a expert in 3d graphics . please let me know how to disable that asset . I can see a ground plane component in Hospital usd with collision mesh and collision plane but didn’t find a way to disable it ,

I changed the approximation to Bounding cube , still no effect the whole robot is still vibrating . Please suggest briefly the steps to took.

You don’t need to change the ground plane. The ground plane works fine. What you should modify is floor assets (e.g. Props/Geo_M1_Floor.usd).

  1. Make collected copy of the hospital.usd environment using File->Collect As… to edit prop files. Your copy should include Props folder.
  2. Open all assets related to floor, remove collider and save.
  3. Check your problems are solved.

Sorry @slowturtle0909 for the late response . I tried manually removing all the collider from each ground related .usd file form the collected asset . but still i am having the same issue.