catastrophic error: cannot open source file "float.h&qu

I have been using the 12.10 PGI C/C++ compilers on MacOSX Lion (10.7.5) since they were released. Just recently, I was forced to upgrade my Xcode developer tools from 4.2 to 4.5, and now the PGI compilers fail with the subject error for any file I try to compile. The particular issue arises at line 57 in /opt/pgi/osx86-64/12.10/include/float.h when it issues a #include_next<float.h>.

Is there an include search path I should add so that the #include_next does not fail?

Hello,

You must reinstall the compilers anytime you upgrade the OS or the Xcode.

Here are some additional things to watch out for

Goto Finder-> Applications -> Xcode
Xcode bar -> preferences -> Components
you will probably see that IOS 5.0 and 5.1 Simulators are installed,
but the ‘Command Line Tools’ is not installed. Install it.

When you try to open the installation files by double clicking, it fails
becausethe file lacked some security verifier.
Instead, right () click on the file -> Open, and then
say yes to ‘Open anyway’ after the same warning

If those steps fail, I will need to see more information about what is
failing.

I hope this helps.

dave

Thanks, that did the trick!