CC4 RTX real-time issues

I have made a body movement for Camilla, this is for News Anchor -style presentation. So shall use this body with A2F.

But as you can see, there are few issues:

  1. the smearing/echo effect at the hair. This is something to do with transparency, I guess? How to fix this?

  2. The straight line at the hairline, it is pretty bad. How to fix that?

I need to stay in RTX real-time mode. Please help if you can?

Yours,
Pekka

When I render this from Machinima 2022.2.0 as RTX real-time, I still have that smearing/echo effect at the hair.

But I also got some flickering going on at her hands…

Hello @pekka.varis! I notified the RTX team at NVIDIA to look into this. I also reached out to Reallusion for help too!

Hi @pekka.varis! Do you have a dome light? The NVIDIA developers suggested that if you do have a dome light, try changing it to env map mode, or try it in sampled lighting.

the smearing/echo effect at the hair

Hi @pekka.varis is motion blur on or off ?
if it was on, does turning it off help to reduce the ghosting effect?

@pekka.varis
I think you should use OmniHair (export using path-traced material will turn RL hair shader into OmniHair MDL)
maybe you can export 2 time (1 real time, 1 path-traced) and change the hair material to the OmniHair

I need to stay in RTX real-time mode

are OmniHair fully support in RTX real-time ?
could @WendyGram ask the Omniverse RTX Render Lead (Ignacio ?) for this question?
I don’t know the answer neither

Thank you!

I tried demo light with Env Map mode, and sampled direct lighting.
Both combinations, as you see:

No help on this.

Realtime RTX render settings / Post Processing motion blur have no effect on this.

But changing the background to darker one kinda hides away this issue. Here is first without sampled direct lighting and then with it:

I think this is pretty ok, but do I have any settings to make the hair not so jagged / noisy ? I believe it is a transparency & antialiasing issue…

About using path traced exported cc4 characters in RTX realtime - hair looks horrible ( toxic avenger style ) , I know that.

@pekka.varis there is a
Enable Opacity Cutout
option on RL realtime export PBR mdl,
default is ON, because RTX Realtime mode didn’t support semi transparency in previous version of Create.
Maybe you could try disable opacity cutout and see if the current RTX RealTime renderer has

support now, you also need to check the preference is enabled
image

1 Like