Centos 7.5 Support for PGI 18.10!!!

Hello.

I’m using PGICE 18.10 with a machine with Centos 7.5 and Tesla V100.

I’m having some issues regarding constant memory copy (invalid device symbol error).

Does PGI 18.10 offcially support Centos 7.5?vidmate mobdro word counter


I saw that PGI 18.4 supports up to Centos 7.4, so I wonder if it is the same for PGI 18.10.

Hi josephkhan,

OS Support is documented in our release notes. For 18.10 see: https://www.pgroup.com/resources/docs/18.10/x86/pgi-release-notes/index.htm#supported-opsys-updates

2.5.1. Linux
CentOS 6.4 through 7.4
Fedora 14 through 27
openSUSE 13.2 through openSUSE Leap 42.3
RHEL 6.4 through 7.4
SLES 12 through SLES 12 SP 3
Ubuntu 14.04, 16.04, 17.04, 17.10

CentOS 7.5 and 7.6 were first supported in PGI 19.1.

Note by “support”, this means the OS which we tested on. Often older compilers will work on newer OS releases, but just weren’t available at the time to allow us to test.

I’m having some issues regarding constant memory copy (invalid device symbol error).

Doubt this error would be a OS support issue, though you can try updating to PGI 19.4 to see if it fixes the problem. If not, please post more details about the error and a reproducing example so we can see what’s wrong.

-Mat