CentOS 7 headless with nVidia drivers installed, OpenGL not using nVidia drivers, only llvmpipe

Hmm, does winbind apply if it’s not samba, but is NFS?

Is this shader cache needed, or is /tmp or a small local disk directory sufficient for it, if I were to set it globally for all users on that server?

I got the impression that you were autheticating against MS AD, usually done via winbind, doesn’t matter if I got it wrong.
The shader cache isn’t really needed, it’s just to improve gaming performance on subsequent runs, can be disabled:
https://download.nvidia.com/XFree86/Linux-x86_64/495.44/README/openglenvvariables.html

Though it smells like a driver bug when failing to create it results in such issues.

Edit: missed you already found the setting.

True! Well then I’ll put it this way. What do you suggest?

If the issue is unavoidable, I’m happy to see about making the change global,
but if you think this is something that the devs could look into, what’s the process for floating that up?

Mail it to linux-bugs[at]nvidia.com

Will do, thanks!!