Centos Dual monitors not working version 430.40 elrepo

Having a hard time getting both monitors to work at the same time. If I run nvidia-xconfig --enable-all-gpus then the hdmi port works but then it doesn’t display on the latop. I believe its a setting in this file just not sure how or what to set it to.

startfresh install then ran this /***********
so at this point I was actually able to get into the machine… After that I followed these steps…
for refrence - https://elrepo.org/tiki/nvidia-detect and https://elrepo.org/tiki/tiki-index.php and https://elrepo.org/tiki/nvidia-detect
Found half of the instructions here - viewtopic.php?t=61162 (thanks TrevorH) -
rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org
rpm -Uvh http://www.elrepo.org/elrepo-release-7. … noarch.rpm
yum install $(nvidia-detect)
yum bumblebee
followed the instructions here - https://elrepo.org/tiki/bumblebee
end fresh install instructions***************************

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 430.40

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1050 Ti"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Another attempt -

ran - nvidia-xconfig --base-mosaic did a reboot -

ran xrandr

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
1920x1080 60.00*+ 59.94 50.00 60.05 60.00 50.04
1680x1050 59.95
1600x1200 60.00
1440x900 59.89
1280x1024 75.02 60.02
1280x960 60.00
1280x720 60.00 59.94 50.00
1024x768 75.03 60.00
800x600 60.32
720x576 50.00
720x480 59.94
640x480 59.94

I have done a bunch of these and can’t seem to get it right… Any suggestions please let me know again. I believe its just the config file but how do I figure out whats what?

This is an Optimus notebook so it requires special setup.
Please use the rpmfusion drivers, those have some packaged the required config, see this:
https://devtalk.nvidia.com/default/topic/1057842/linux/hp-laptop-with-fedora-hdmi-monitor/post/5364500/#5364500

Thank you. How do I find the .run file? I mean it should be somethingXXX.run correct? Where would I find that at?

https://rpmfusion.org/Howto/NVIDIA#Current_GeForce.2FQuadro.2FTesla
https://rpmfusion.org/Configuration/

I went to both pages and I did not see a .run - or instructions to uninstall a .run file if that helps any.

Skip that part, the user in that thread used the nvidia web installer. Instead, uninstall the elrepo packages and use the ones from rpmfusion instead.

Sorry I misread that. ha it is a Approved Repositorie

Still only getting one display :(

xandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1920x1080 59.98*+ 59.97 59.96 59.93
1680x1050 59.95 59.88
1400x1050 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 60.02
1400x900 59.96 59.88
1280x960 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1280x800 59.99 59.97 59.81 59.91
1280x720 60.00 59.99 59.86 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
700x525 59.98
800x450 59.95 59.82
640x512 60.02
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
640x400 59.88 59.98
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32

I didn’t do anything under special notes - https://rpmfusion.org/Howto/NVIDIA#Current_GeForce.2FQuadro.2FTesla

is something else required?

Now if I run any of the nvidia-configs like
–base-mosaic I can’t even get the hdmi to work at all. With elrepo I could… I am not sure that helps any… Not sure where to go from here.

I tried https://rpmfusion.org/Howto/Optimus nothing on that… :(

Trying cuda now. Cross your fingers. sudo dnf install xorg-x11-drv-nvidia-cuda

UPDATE - nothing… I think I may just go back to elrepo as at least I could get one screen or the other to work. Honestly not sure what to do or try now.

Tried uninstalling and reinstalling everything. Also tried a fresh install centos too… I am sure I am missing something silly.

don’t create an xorg.conf at random. Please delete it, reboot, then run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

thank you. here is your log. For the record I only created it after everything else failed then deleted it.
nvidia-bug-report.log.gz (69.3 KB)

Looks like the packages for Centos don’t fully set this up yet. Please use (c/p) the xorg.conf and create the .desktop files for Gnome like here: https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

thanks. I will try in a week or too. I may just go back to elrepo then. I figure that should work fine with the other config. Right? any thoughts? At least with elrepo I can get other monitors and it seems like more stuff is supported too.