CentOS7 install deepstream

**• Hardware Platform (Jetson / GPU)**GPU
• TensorRT Version
• NVIDIA GPU Driver Version530.30.02
• Issue Typequestions

Can I install DeepStream on my CentOS 7 server with an A30 graphics card? If so, what version should I install?

The old DeepStream 5.0.1, 5.1 and 6.0.1 supported RHEL8.x. Quickstart Guide — DeepStream 6.0.1 Release documentation

No DeepStream version supported CentOS 7 .

What if I use a docker container? I found that only versions above DS6.1 support A30 graphics cards. Has anyone tried this and succeeded?

There is no docker for CentOS.

It is not recommended to try the versions which are not verified.

I mean, could I install Docker on Centos 7 and pull the Deepstream 6.1 image? And can I install Tensorrt on Centos 7?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

  1. TensorRT does support CentOS, you can install TensorRT on CentOS. Log in | NVIDIA Developer
    Quick Start Guide :: NVIDIA Deep Learning TensorRT Documentation

I don’t think it can work since DeepStream needs the host driver matching.

You will need to install the NVIDIA GPU driver for your A30 graphics card first. You mentioned that you have version 530.30.02 installed, which should be sufficient.

After installing the driver, you can download and install the appropriate version of DeepStream from the NVIDIA Developer website. Make sure to select the version that matches your desired version of TensorRT, as different versions of DeepStream are compatible with different versions of TensorRT.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.