Cesium | Particles Error | USD Composer 2023.2.0 Beta

Getting error when trying to add particles after enabling Cesium extension on USD composer 2023.2.0 Beta. Though the error is the same in the prior versions of USDComposer as well. Please help if there is a alternative approach to adding particles along with Cesium extension enabled

@ratan.s.murali do you happen to have the fabric scene delegate enabled in your preferences > rendering setting?

Go into Preferences and then turn off FSD (fabric scene delegate) and see if that solves it.

fabric scene delegate is enabled as it is a requirement from Cesium extension kit for its working. Disabling fabric delegate → particles does work without any issues.

Ok so you are seeing a direct conflict between the need for FSD on for Cesium and off for particles ? I will talk to the Devs and get back to you

1 Like

After talking to the Devs, we have determined that indeed, you need FSD on for Cesium and we are aware that with FSD on, Particles may not work. This is unfortunate. The good news is that we have it working here now, so it will be in the next major branch release of Composer. We have made massive improvements to FSD

Thank you!

I have a similar problem,enable fabric scene delegate ,Example no longer works

omniverse also crashed

@29009344 a few things that may help the mods/devs help facilitate the troubleshooting process:

  • upload the most recent Composer log found in the directory: %userprofile%\.nvidia-omniverse\logs\Kit\USD.Composer\2023.2 (Windows) or ~/.nvidia-omniverse/logs/Kit/USD.Composer/2023.2 (Linux)
  • write out the steps you took that lead to the crash, so they can try to reproduce and pinpoint the issue

better yet, make a separate thread since this may not pertain to Cesium.

step1. enable FSD in Edit>Preferences>Rendering
step2. open a sample just like “path-points” in Window>Browsers>Examples
step3 . click play then composer 2023.2.1 crash

kit_20231217_100458.log (1.4 MB)

i can repro on my end. and, from both of our logs, it looks like there’s incompatibility between fabric and action graph (or specific/combination of the nodes used) in 2023.2.1:

2023-12-17 02:11:39 [400,901ms] [Error] [usdrt.population.plugin] Failed to write attribute /World/ActionGraph.fileFormatVersion to Fabric. Mismatch between bytes to be written 8 and attribute size in Fabric of 16.
2023-12-17 02:11:39 [400,905ms] [Warning] [omni.anim.skelJoint.plugin] Obsolete SkelJoint persistent data existed in this USD stage for Skeleton /World/Character/Root in layer https://omniverse-content-staging.s3.us-west-2.amazonaws.com/Assets/AnimGraph/105.0/Characters/NVIDIA/biped_demo.usd

i tested with 2023.1.1 as well. whilst it doesn’t seem to crash, the behavior on the animation examples will lock the mannequin in place, so the mods/devs will have to take a look at it.

Consistent with my test results,how to fix it ,only wait???

likely the case. or don’t use FSD on certain animation examples that crashes (FWIW, not all of them crash).

We are releasing a new version very soon, I will keep track of this issue with the Devs.

  1. Try not setting the memory allowance so high to 90%.
  2. Try to run through the animation timeline and help cache it up before you enable FSD.
  3. Try to enable FSD and then quit the app and restart it. Leave it on

thx,I need FSD because I need cesium sence, please fix this bug as soon as possible.
I cannot understand the third suggestion
Did I follow these suggestions and it’s possible that they will run normally?

i try 1.2 no use

for 3) I mean enabled FSD on a blank default scene, and then quit and restart Composer. It stays on now with that setting. After restarting the app, trying to work normally. I am just asking that you enable FSD and then restart the app before trying your scene that crashes,

unfortunately,I restart the app,setting lost, Is there anything wrong with my operation

I thought that the FSD setting was permanent after a restart. Strange. Can you please go to Preferences and use the “Reset to Default” in the top left corner of the preferences. Let it restart and try that.

i just test composer 2023.2.2 ,the bug still exists