Change Pivot not working

Hey,

I need to change the pivots of my generated usd files to use the rep.randomizer.scatter_2d function. So far the different objects with their different pivots appear under the plane and thus I’m not able to use the scatter function properly so far.

I tried right click on the prim → add → TransformOp → Pivot and then tried to change Translate:Pivot in the properties. Instead of moving the pivot, my object translates to that position and the pivot is the same.

I’m using Isaac Sim 2022.2.0 if that helps.

I’m happy for other workarounds, too.

Thanks a lot!

Hello @hugo.81243, thank you for reaching out. We will look at better handling pivot xform ops. For the time being, the suggested workaround is to use rep.modify.pose(pivot=(<relative pivot in x, y, z>)) command:

import omni.replicator.core as rep

plane = rep.create.plane(scale=10)

with rep.randomizer.instantiate(["/path/to/pivoted/asset.usd"], size=100):
    rep.modify.pose(pivot=(0, -1, 0))
    rep.randomizer.scatter_2d(plane)

Please let us know if this does not resolve the issue for you.