change usbcore.usbfs_memory_mb [SOLVED]

I need to change the parameter usbcore.usbfs_memory_mb, that on the TX2 I usually change in the conf file:


Now I’m trying to do the same with the Xavier (Jetpack 4.2), but there is not the same file. I also noticed that there is the folder of the GRUB bootloader, but Grub is not installed.

I tried to append the line:

APPEND ${cbootargs} usbcore.autosuspend=-1 usbcore.usbfs_memory_mb=256 root=/dev/mmcblk0p1

in the configuration file (on the host pc):


I re-flashed the Xavier with this configuration file, but nothing changed, the value returned from the command

cat /sys/module/usbcore/parameters/usbfs_memory_mb

is still 16.

How can I do this change in the Xavier?


“extlinux.conf” is not used anymore on recent and semi-recent releases of L4T. Try to instead edit the “chosen/bootargs” entry in the device tree, and flash the device tree. Make sure to revert any extlinux.conf changes you may have made.

Thank’s linuxdev!

We solved the problem re-flashing only the kernel with the command

sudo ./ -k kernel -C "usbcore.usbfs_memory_mb=512" -k kernel-dtb jetson-xavier mmcblk0p1

We didn’t need to change anything in the Nvidia original files (except revert our previous changes), perfect, thank you!

Hi, is there any way to do it using the JetPack 4.4 via SDK Manager? Or perhaps using a command line version of sdk manager would be great.

I suppose, as an alternative, I can use the sdk manager to download and build the image and leave the flash as a manual step?

Thanks a lot.

You can easily flash with that version of JetPack/SDKM. If you have ever flashed with this, then you will already have the “driver package” installed on the host PC (JetPack/SDKM is a front end to the driver package). That content is here:

The command line tool at that location is “”. You can use the commands listed above, or ask for other use cases. In the past the Xavier has not used U-Boot, but over time U-Boot functionality has been added back in to emulate this with the CBoot mechanism. You might be able to just copy an Image file in some releases, but require kernel flash in other cases.

Thanks, that actually worked on Jetson Xavier by adding the usbcore.usbfs_memory_mb=256 in the APPEND line on /boot/extlinux/extlinux.conf.