Changing vdd-rtc for custom carrier board


I’m using Jetpack 4.5.1 TX2 and would like to change the rtc voltage for a custom carrier board to 3.3V.

I see that the max77260.c has a function for backup battery and have made the following change in the device tree.

  backup-battery {
                                backup-battery-charging-current = <0x190>;
                                backup-battery-charging-voltage = <0x325aa0>;
                                backup-battery-output-resister = <0x64>;
                                status = "okay";

And here is the vdd-rtc node ldo4.

ldo4 {
                                        regulator-name = "vdd-rtc";
                                        maxim,active-fps-source = <0x0>;
                                        maxim,active-fps-power-up-slot = <0x1>;
                                        maxim,active-fps-power-down-slot = <0x7>;
                                        regulator-enable-ramp-delay = <0x1a>;
                                        regulator-disable-ramp-delay = <0x672>;
                                        maxim,ramp-rate-setting = <0x186a0>;
                                        regulator-ramp-delay = <0x80e8>;
                                        linux,phandle = <0x17a>;
                                        phandle = <0x17a>;

If i try adding the following to ldo4 ie vdd-rtc then the jetpack does not reboot, thus crashes.

regulator-min-microvolt = <0x325aa0>;
regulator-max-microvolt = <0x325aa0>;

Also, when i run,

dmesg | grep rtc

i get the following as a response :

[ 0.565475] vdd-rtc: at 800 mV

Would like some insight on the same, Thanks

Apologies, we have found out that there was error in the hardware.

You may delete this post if required but this is a working summation for the same.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.