Chat with RTX error - Could not import sentence_transformers python package

HI
script stopped to “ImportError: Could not import sentence_transformers python package. Please install it with `pip install sentence-transformers”
I install sentence-transformers in bash but it doesn’t work

1 Like

I have the exact same problem. I tried everything, but I’m stuck on that error ‘ImportError: Could not import sentence_transformers python package.’

Uninstalled Python
Uninstalled Chat with RTX
Cleaned registry and trash
installed Chat with RTX
The problem remains…

I wonder if it’s because I’m on windows 10 while the requirements say that you should have windows 11…

Hello. I have the same problem and I am running the chat RTX with windows 11

same problem here

I managed to fix it by running: pip install -U sentence-transformers

I am using Windows 10 and it seems to be ok now after that.

1 Like

I decided to take a workaround:

  1. Download sentence-transformers (.tar.gz) directly from pypi
  2. Unpack the folder from the “sentence_transformers” archive to the path ‘C:\Users\user\AppData\Local\NVIDIA\ChatWithRTX\env_nvd_rag\Lib\site-packages’
2 Likes

good idea is work thx u

Went to pypi… so many “sentence-transformers” packages.
Which one do I download for Chat with RTX?

this one worked for me.

thank you for the solution, it worked for me. to be more specific, you must choose the version 2.2.2 of sentence-transformers, and indeed, only copy the folder named “sentence_transformers” from the unzipped package.

Thanks everyone for your suggestions, I have a Lenovo i9 laptop, 32 GB RAM, Nvidia RTX 4080 with 12 GB of VRAM, 1TB SSD, and Windows 11. I have tried everything suggested on this forum including turning off my Firewall and virus protection and I still get the same error when I try and start the app, it can’t find the huggyface sentence-transformers. Does anyone have a solution because I am about ready to give up on Chat with RTX?

plz help~

[03/25/2024-22:54:56] You try to use a model that was created with version 2.5.1, however, your version is 2.2.2. This might cause unexpected behavior or errors. In that case, try to update to the latest version.

100% none professional haha…

Solved here: Rtx with Chat successfully installed but causes error when run - #4 by aakashr1996

can someone post step by step pics because I’m really clueless

I unpacked version 2.22 , then unpacked it again. took the 2 directories and placed them where you said.

Worked like a charm!!