[ChatWithRTX] Cannot launch it - ImportError

Hello everyone
I recently (yesterday) bought a RTX 4070 TI Super to try Chat With RTX, because I want to experiment with a RAG
The install went great, no issue whatsoever.

Though, when I run it, I get this message error

ImportError: DLL load failed while importing MPI: Le module spécifié est introuvable

(previous messages for context :


)

As you can see, I changed the directory for the install. But don’t get me wrong, I tried to install it on the recommended path and got the same error.

Apparently, it fails to find the module. I tried to run it as admin, got another error :

python: can't open file 'C:\\Windows\\System32\\verify_install.py': [Errno 2] No such file or directory
python: can't open file 'C:\\Windows\\System32\\app.py': [Errno 2] No such file or directory

Which is normal I guess since there is nothing in the system32 folder

My coworker tried it two days ago with great results on a RTX 3070 and didn’t get this error, it ran smoothly

What could be the issue ? Because the models do get recognize at the beginning, and they are installed correctly in the folders.

I obviously tried to reinstall it (with a clean install), and restarted my computer. Nothing changed though…

Thank you for your help !

Problem solved : I downloaded Microsoft MPI setup, and it now works perfectly :)

You can find it here : https://www.microsoft.com/en-us/download/details.aspx?id=57467.
Thanks PL-AD on github for the hint

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.