check to see if flexlm works correctly?

I have just installed pgi workstation for the first time, and am somewhat of a newbie. Will untimately use pgi to build GAMESS, PSI3.2, and other computational quantum chemistry codes.

My machine is a single processor sun ultra 20 (opteron 152) running SuSE 10.

I installed pgi as root and may want to use it as root as well as when logged in as a user so generated flexlm licenses. I think (but am far from sure) that I put things in the correct places to start the flexlm manager at boot time. Lack of confidence is related to redhat directions being mapped onto SuSE.

After this setup I re-booted machine for test, logged in as a user and ran the suggested version test. I got the following:
willsd@ip-152010150166:~> pgf77 -V x.f

pgf77 6.1-1 64-bit target on x86-64 Linux
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2005, STMicroelectronics, Inc. All Rights Reserved.
NOTE: your evaluation license will expire in 14 days, 20.9 hours.
For a permanent license, please read the order acknowledgement
that you received. Connect to with
the username and password in the order acknowledgement.

Name: “steve williams”
User: root
Hostid: PGI=00E081E05542757C10B9EE
PGFTN/x86-64 Linux/x86-64 6.1-1
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2005, STMicroelectronics, Inc. All Rights Reserved.
PGFTN-F-0002-Unable to open source input file: x.f

I think that this means that my flexlm licenses are being ignored and that the default 15 day temporary license is being used instead. Is this the case? How can I check to be sure that the license manager has been started properly and is running?
Or maybe it is the case that the 15 day temporary license is always used untill the 15 day period has expired, then the system looks for (and hopefully finds) the permanent license…

Steve Williams

Hi Steve,

The abbreviated steps to setting-up a license are:

  1. Go to and generate a license.

  2. Put the resulting keys in a “license.dat” file. This file typically is put in the base PGI directory ($PGI) but can be put anywhere. Be sure to set $PGI to the correct directory and LM_LICENSE_FILE to the actual path to this file.

  3. Set up your configuration.

   setenv PGI /usr/pgi
   set path=($PGI/linux86/6.1/bin $path)      ! for 32-bit by default
   set path=($PGI/linux86-64/6.1/bin $path)   ! for 64-bit by default
   setenv LM_LICENSE_FILE $PGI/license.dat

or in bash

  export PGI=/usr/pgi
   export PATH=$PGI/linux86/6.1/bin:$PATH     ! for 32-bit
   export PATH=$PGI/linux86-64/6.1/bin:$PATH  ! for 64-bit
   export LM_LICENSE_FILE=$PGI/license.dat
  1. If you need to run lmgrd, make sure it is not running already
   ps ax | grep lmgrd

Let it run if it is already running, or kill it and start our
version, which may be different (could be better)

Use the following to command to start the licence manager:

$PGI/linux86/6.1/bin/lmgrd.rc start

Some ideas for you is to make sure lmgrd is running, you have LM_LICENSE_FILE set to the correct license.dat file, and that you remove the eval license.

  • Mat

One of my problems is that I can’t tell if lmgrd is running… I can check with ps -e or (as you suggested) ps -ax but do not see anything that looks like lmgrd in the lists provided. This is same if I run the lmgrd.rc start or not.

BUT I do see something interesting if I run the start and then try the corresponding stop:

ip-152010150166:/usr/pgi # lmgrd.rc start
ip-152010150166:/usr/pgi # lmgrd.rc stop
lmutil - Copyright © 1989-2004 by Macrovision Corporation. All rights reserved.
Shutdown failed: Cannot connect to license server system. (-15,570:115 “Operation now in progress”)

No error message from the start, but the stop can’t find the license server, which is the same machine…

Also, per your suggestion, I commented out the lines related to the default license (generated with the install), then tried the version test again.

This is what I got:
ip-152010150166:/usr/pgi # pgf77 -V x.f

pgf77 6.1-1 64-bit target on x86-64 Linux
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2005, STMicroelectronics, Inc. All Rights Reserved.
pgf77-linux86-64: LICENSE MANAGER PROBLEM: Failed to checkout license
pgf77-linux86-64: LICENSE MANAGER PROBLEM: Cannot connect to license server system.
The license server manager (lmgrd) has not been started yet,
the wrong port@host or license file is being used, or the
port or hostname in the license file has been changed.
Feature: pgf77-linux86-64
Server name: freesun
License path: /usr/pgi/license.dat
FLEXnet Licensing error:-15,570. System Error: 115 “Operation now in progress”
For further information, refer to the FLEXnet Licensing End User Guide,
available at “”.

This was after running the lmgrd start command.

So, I clearly have a flexlm license problem…

Do you know if there is a “backdoor” way to speak to an engineer at PGI? I think a short phone conversation with an expert would likely solve my problem with flexlm. I have tried the trs email, but have not gotten a reply in 2 days.

TIA for any additional help you may have for me.

Hi Steve,

I just talked with Dave who answers TRS and unfortunately did not get your first mail. However, he did get the one your sent to forwarded to him and should be responding shortly. If needed, Dave may give you call or ask if he can access your system, but he’ll try to resolve the issue via email first.

While Dave is the expert when it comes to licensing issues, I’m do know that lmgrd needs to establish a TCP/IP connection. Could something be preventing this, such as a firewall? Are you able to telnet to yourself?


I have the suse firewall set so that telnet is not accepted but ssh is.
I cannot telnet to (my suse box’s ip) since I get a
connection refused error message, but I can ssh to the same ip with
no trouble. So I do have TCP/IP but not telnet. Is there some other
service I should allow through the firewall to get flexlm to work? Right
now only ssh is permitted through.


BTW: I did get a couple of emails from Dave but the problem is not resolved and I have not heard from him since the 12th. (It is now the 16th).

Hi Steve,

To use lmgrd through a firewall, you first need to fix the port which lmgrd listens on and then fix which port pgroupd uses. (See the PGI Installl FAQ page). Note that Macrovision has recently changed their recommended lmgrd port to 27000 (See Here)

You’ll then need to change your firewall rules to allow these ports (at least from the localhost). When googling this problem I did find one post which showed how to use a ssh tunnel but I have not tried this solution before myself so don’t know if it works.

Hope this helps,

OK, the PGI FAQ shows how to change the port number by changing the fourth field on a line that looks like:

SERVER 0090123c30e8 7496

BUT it does not (at least I think not) say what file contains this line to be edited…

I’ll do the edit and test that (and set my firewall to let this through), but I need to know what file has the line to change.


Hi Steve,

You need to edit your license file (license.dat) and replace the “SERVER” and “DAEMON pgroupd” lines.

  • Mat