clean physx/apex from maya scene for UE4 import

hi there :)

I just quickly wanted to ask what would be the best way to completely clean apex/physx from a maya scene?
I have a rigged model and I applied apex to her hair.

at some point in the process for some unexplainable reason the hair kinda broke.
it looks fine in maya but broken in UE4. I tried to delete everything physx related from the scene, I also deleted the history of the hair geo and re-skinned it, but to no avail.
as soon as I apply apex cloth again it has the same error in ue4 :/

how to I get it completely cleaned from a scene? any tips?

thank you very much in advance,
chris

I do not understand the problem you are facing. If you want to clean PhysX things from your sample, you can do it in the following steps.

  1. iterate all of the PhysX objects and remove PhysX object via PhysX Menu. Assume you have a box as rigid body, you pick it and go to menu Physx -> Rigid Bodies -> Delete Rigid Body. For clothing, you need pick and go via clothing’s sub-menu.
  2. go to menu Windows -> Hypergraph: hierarchy. delete PhysX and nxRigidSolve.
  3. Save to disk as ascii mode. Now you can try it again with UE.
  4. Optional(if you still have problem with UE): open the saved ascii mode Maya file in a txt editor. Need delete the following keyword (nxRigidSolver and NvLocator) in the middle of the .ma file: e.g.
    createNode NvLocator -s -n “nimaPhysicsLocator” -p “nxRigidSolver1”;
    setAttr -k off “.v”;
    setAttr “.lbl” -type “string” “”;
    Remove this field and other field by searching the above two keywords.

let me know if you still have problem.

hi juma!

thanks a lot for the reply, I’ll try that when I’m home tonight.

and sorry if I didnt make myself very clear.
basically I’m applying apex to a mesh… it used to work perfectly fine.
I imported the mesh into UE4, added the apex (which I had just exported from maya) and it was all good; the hair was moving in the wind so to speak.

however, at some point I did something that broke the hair. from that point on whenever I exported the model (because I was still in the process of painting the skin weights, it wasn’t like a done rig or anything) and imported it into UE4 some of the hair would snap to some kind of invisible plane somewhere in space. like the hair geometry would just stretch out and hit some … barrier… off to the side of the character.

so I thought in order to fix this I just remove the kinetic ragdoll, delete the entire history of the hair (to remove cloth) and re-do the whole procedure.
however, turns out that even if I re-do everything the problem still persists.
so I figured there must be something left behind that I forgot to delete.

I’ll test your method later.
thanks very much! appreciated!
chris