Clock and Date Problem on L4T on Jetson TK1

Hi, I have a problem with the clock and date of my board. This board doesn’t update the clock with NTP. Why?

Usually it would be because of DNS not working while trying to update. Is the content of /etc/resolv.conf updated, or a basically empty file with nothing other than a comment? If you do host name lookups, does this work? E.G., “host” should find the domain.

In my resikv.conf there is:


That is a non-internet routable address. If this address forwards to a DNS server (such as through a router) it will work…if this isn’t a forward to a DNS server then NTP cannot work. Does “host” respond or fail? This will tell you if DNS is working.

do you mean ping

Either ping or host command would answer this most of the time. The “host” command says to look up the name and provide a dotted-decimal address; in the case of “ping” it doesn’t tell you the IP address except as a side-effect. Unless your “host” command is missing (this is a very fundamental command, used to be “nslookup” a long time ago), I’d do “host” instead of “ping”.

Yes host works fine :)

Ok so all is capable of finding and setting date. Does the following work to manually set date?

sudo service ntp stop
sudo ntpdate -s
sudo service ntp start

Anything changed. :( While reboot the board the date is 1 Jan 2000 1:00

So from the last answer I’m not sure if you were able to temporarily do the manual ntpdate successfully. The reason this is needed is that after boot completes and you know “” can be resolved a successful manual update proves ntp is set up correctly; if it still fails during boot it implies that DNS resolution or networking was not started prior to the automated ntp date setting…which almost always implies DNS rather than networking as a whole. DNS must work prior to ntp working.