CMake warning while cross-copiling driveworks-1.2 samples

Hello,

I’m following the guidelines on this post to cross-compile the samples in driveworks-1.2:
https://devblogs.nvidia.com/drivepx-application-development-using-nsight-eclipse-edition/

However, when I do

'sudo cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_TOOLCHAIN_FILE=..."

many warnings are displayed for each add_executable:

CMake Warning at src/dataspeedBridge/CMakeLists.txt:30 (add_executable):
  Cannot generate a safe runtime search path for target
  sample_dataspeedBridge because there is a cycle in the constraint graph:

    dir 0 is [/usr/local/driveworks-1.2/targets/aarch64-Linux/lib]
    dir 1 is [/usr/local/cuda/targets/aarch64-linux/lib]
    dir 2 is [/usr/local/cuda/targets/aarch64-linux/lib/stubs]
    dir 3 is [/home/reway/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-linux/lib-target]
      dir 5 must precede it due to runtime library [libXrandr.so.2]
      dir 6 must precede it due to runtime library [libX11.so.6]
    dir 4 is [/usr/local/driveworks-1.2/samples-original/3rdparty/linux-aarch64/vibrante/lib]
    dir 5 is [/usr/local/driveworks-1.2/samples-original/3rdparty/linux-aarch64/vibrante_Xlibs/lib]
    dir 6 is [/home/reway/nvidia/nvidia_sdk/DRIVE/Linux/5.0.10.3/OS/DriveSDK/drive-t186ref-linux/targetfs/usr/lib/aarch64-linux-gnu]
      dir 5 must precede it due to runtime library [libXrandr.so.2]

  Some of these libraries may not be found correctly.

Is there some lib path missing so the following libs can properly be found?

Thanks

1 Like

Dear Reway,
Can you confirm if you have checked the prerequisites/instrcutions at file:///usr/local/driveworks-1.2/doc/nvdwx_html/dwx_samples_building.html.
Also, can you check if you have installed r396 driver which is required for CUDA 9.2

I have encountered this exact issue as well. I have verified that I have followed the steps in the documentation, and I was previously able to cross-compile Driveworks 0.6 without issue.

Hello SivaRamaKrishna,
Yes, I do have the libs described in the docs and driver 396.54 installed (via apt nvidia-396). My graphic card is a GTX 750.

It seems that I have a problem with CUDA. Since I cannot even run the exemples on the hostpc.
The following error will appear multiple times when I run “sample_drivenet”:

[16-10-2018 19:55:45] CUDA cask failure at execution for trt_maxwell_scudnn_128x64_relu_medium_nn_v1.
[16-10-2018 19:55:45] caskConvolutionLayer.cpp (195) - Cuda Error in execute: 48

Hello matt.harrison,
Yes, I was able to compile DriveWorks 0.6 without any of these warnings too.

Any updates on this issue? It seems that both Reway and I are following the documentation exactly, but have no ability to run even the sample applications on the device.

Dear matt.harrison,
I have tested it on my machine(freshly installed ubuuntu 16.04 with GTX1070 GPU and GPU driver installed via ubuntu software center).
I too got these warnings with cmake. But I can see make files got generated and could generated cross compiled binaries for the samples after running make.

Can you confirm if you could not generate cross compiled binaries for samples after running make? If not, could you please paste the log of both cmake and make commands

Dear matt.harrison,
There’s also another topic related to this:
https://devtalk.nvidia.com/default/topic/1042526/driveworks-1-2-samples-compilation-error/#529098

The solution there did not work for me, however, check if it does work for you.

Dear Reway,
If the issue is still not resolved, could you please post the log of cmake and make commands here

Siva and Reway,

Thank you for the responses. Following the steps in the thread linked by Reway removed all the errors during “make install”. While the warnings are still generated during the “sudo cmake -DC…” call, it seems that I am now able to both compile and run the sample applications on the device.

Once again, thank you for your responses.

1 Like