Code 2023.1.1 crashes when running headless

Today I updated to the new version of Code, but unfortunately Code crashes when I try to run the scripts I already created? Maybe you can provide any insight on what could possibly be wrong?

crash_2023-08-07_13-12-32_5732.txt (8.8 KB)

@julian.grimm were you using any extensions prior to upgrading to the most recent version of Code? i noticed the latest version disables several extensions by default, so if you were using any, you’d probably want to consider switch them to autoload. though, not sure if that’s the issue you are having.

Beside Omniverse Replicator, I am not using any extensions. I noticed that Autoload was not active for Omniverse Replicator, however that did not fix the problem for me. I think the crash has something to do with this warning:

After further testing I figured out, that using instead of calling it async fixes the problem. However the rendered images look stretched out. This happens in headless mode, but also when starting replicator through the GUI:

code: (10.4 KB)

After further tracking down this issue, I can say that reducing the resolution of the render product to 2048x2048 fixes the stretching for me:

If I increase it to 2049x2049 again I get the same stretching effect as above:

that’s…interesting. how about anything past 2049x2049?

If I increase the resolution further the stretching stays the same, I tested inceasing it in steps of 100 pixels ( ==> 2148, 2248, 2348…). Also the issue stays if I change the resolution to non square values (e.g. 2448 x 2048).

and is it safe to assume anything smaller than and equal to 2048x2048 would be okay?

I tried 2047x2047 and 2046x2046 and get this result for both resolutions:

I also tried 1500x1000 and got the same stretched image as in my above posts:

This is a very weird behavior and I have not found a pattern yet.

does seem like a bug alright. i wonder what the dev would think it is.

Although I am not able to test all resolutions I think only resolutions that are multiples of 64 work. If I use 32x32 for instance, I get a weird raster in the image:




@julian.grimm We’ve seen this bug also. Its a stride issue in non power of two render products. Can you try running Code with --vulkan in the command?

Drop this into omni.code.bat … something along the lines of:

@echo off
call "%~dp0kit\kit.exe" "%%~dp0apps/omni.code.kit" --vulkan  %*

Let me know if this works.

Thank you for your answer. I can confirm that adding --vulkan solves the issue for me:

1 Like