Codeworks failed to download Android tool chain and SDK platforms

Version 1r7, the download always failed for android tool chain and SDK platforms.

Version 1r6 doesn’t have the issue.

Hi Sioyn,
Did you try to download the other stuff provided by codeworks or only these 2 things are failing? What system are you using? what did you see on screen when it fails? a scrrenshot would be great.

Thanks.

My problem is the same,Version 1r6 doesn’t have the issue,Version 1r7 download Android tool chain and SDK platforms failed display download(error) How to solve it?

My problem is the same ,Version 1r7 download error .on the mac. macos mojava,10.14

Hi everyone,
In Codeworks Version 1R6, the installer was downloading the Android NDK, SDK stuff from a NVIDIA server, we had all needed tools for codeworks there.
However, because of some legal issue, start from 1R7, all those google owned tools are required to be downloaded directly from google server.
I just tested these downloads by myself, they are working fine. It would be great if you can check your internet, firewalls settings, etc. Also, if you are located in some countries that may have country wide firewalls. You may need either to do some other set ups for visiting google’s server or to download those google related tools from some other resources.

I can use the Internet to download the NDK from the official website of Android, but I can’t download it with chooser. Why? I can access the google service

I need to your sdk with UnrealGame,on the mac

Hi 779683637,
Here is the exact link we use for downloading NDK, can you please check if it works for you?
http://dl-ssl.google.com/android/repository/android-ndk-r15c-darwin-x86_64.zip

It downloads ok.

but I can’t download it with chooser

Anyone can fix this problem?

I can not download the build-tools_r26.0.1 from Google,please help me if someone can get it.

Hi,
What system are you using. Did you try to download it directly from google?

I have experienced the same issue with the latest 1R7 version. I am up to build a prototype on UE4 and it requires to install Android SDKs some of those fail to download.

Example: https://gyazo.com/ffda32e8226db887155d7b637478cfb5

I am also facing the same problem.

Hi aleksei.kornishev, vipuljadhav401
Are you able to solve this problem?
First you can try close the codeworks, restart your machine, and retry the installation.
If it still doesn’t work for you. Please share the detail information.

What OS are you using?
Which components are failing?
Is there any Error Message? What is it if so?
Did it failed on downloading or installing?

Screenshot would also be helpful.

Hello,

I haven’t been able to solve the issue.

I have tried 2 versions of CodeWorks to install 1R7. 1R6. The particular component that fails to download is Android SDK Support Library (version 23.2.1). I use Windows 10, it is a corporate machine with firewalls and corporate protection systems. Without any doubt it may affect the process but this time I don’t feel that is the case because I can download the other components and manipulate with the rest of the archive.

On the latest CodeWorks version the component fails to be downloaded, restarts its download 10 times and aborts the installation process. On the 1R6 versions it fails with the error ‘Return Code 2, Error 1, Zip: not a valid Zip file’.

1R7 fail state screen: https://gyazo.com/ffda32e8226db887155d7b637478cfb5
1R6 error message: https://gyazo.com/af7e88abd62ca43282bfb51a3b8aae79

I want to install the codeworks components to package a game built for Android in UE4.

The problem has been solved. That was a wrong call since I had had a firewall issue. When I brought the PC to another network everything went well.

Thanks.

My problem is the same ,Version 1r7 download error .on the mac. macos mojava,10.Tutuapp 9Apps ShowBox

[quote=“779683637, post:4, topic:68513”]
My problem is the same ,Version 1r7 download error .on the mac. macos mojava,10.14