Colcon build of ros2_workspace results in stderr: isaac_ros_navigation_goal

colcon build of ros2_workspace results in stderr: isaac_ros_navigation_goal

Finished <<< isaac_ros2_messages [0.38s]
— stderr: isaac_ros_navigation_goal
/home/meta/.local/lib/python3.8/site-packages/setuptools/dist.py:717: UserWarning: Usage of dash-separated ‘script-dir’ will not be supported in future versions. Please use the underscore name ‘script_dir’ instead
warnings.warn(
/home/meta/.local/lib/python3.8/site-packages/setuptools/dist.py:717: UserWarning: Usage of dash-separated ‘install-scripts’ will not be supported in future versions. Please use the underscore name ‘install_scripts’ instead
warnings.warn(

Finished <<< isaac_ros_navigation_goal [0.72s]

Summary: 6 packages finished [0.89s]
1 package had stderr output: isaac_ros_navigation_goal

I personally cannot repro this, but according to some other ROS users, this warning shouldn’t affect the building of the package. But if it’s annoying, you can try to go into ros2_workspace/src/navigation/isaac_ros_navigation_goal/setup.cfg and change both the script-dir and install-scripts to use the underscore, and see if the warning goes away.