Collision Groups not working

Hi,
I tried using collision groups and its not working as expected. I read the documentation it says:

  • Currently, collision groups cannot be changed during simulation and require stopping and restarting the simulation. This will be addressed in a future release.

So how do I restart the simulation?

Btw Filtered Pairs is working fine.

Hi,
Can you please give me more details what is not working with collision groups for you? It is now not possible to change their properties while simulation is running (play is pressed). Restarting simulation means, pressing stop and then play again, this will trigger full reparse of the stage.
The collision groups feature is shown in the Collision Group Snippet, you can view it in the Physics demos (Window->Physics->Demos).
Regards,
Ales

Colliders.usd (648 KB)
Hi, have attached a sample file demonstrating the colliders. Created 2 Colliders Groups using spheres and cubes and added filtering. The expected result is the spheres shouldn’t collide with the cubes, but didn’t happen.

image

Hi,
I did take a look at the asset, there are some issues I can see:

  1. CollisionGroups are not derived from Imageable, so if you put the meshes under them you wont see them.
  2. Putting primitives in a hierarchy under a collision group does not mean they are assigned into the collision group. Prims that belong to a collision group are defined through a collection that is automatically assigned to a collision group. So you need to change the collision group collection to include prims that you want.

I am attaching fixed asset, it should look like this.

Colliders.usd (649.1 KB)
Regards,
Ales

Thank you so much for the clarification, this sample file is very helpful.