Color banding and animation issues with 520.56.06

Issue still happening with the suggested fix

Can you please try below steps once and share test results again.
1)After booting to console mode, reinstall driver
2)rmmod nvidia_drm nvidia_modeset
3)modprobe nvidia-modeset output_rounding_fix=0

What I did:

  1. Disabled sddm.service → Rebooted to Console
  2. Re-Installed nvidia by firstly removing sudo mhwd -r pci video-nvidia and then reinstalling sudo mhwd -a pci nonfree 0300
  3. Executed sudo rmmod nvidia_drm nvidia_modeset
  4. Executed sudo modprobe nvidia-modeset.output_rounding_fix=0

The command sudo modprobe nvidia-modeset.output_rounding_fix=0 failed with the error: modprobe: FATAL: Module nvidia-modeset.output_rounding_fix=0 not found in directory /lib/modules/6.0.14-1-MANJARO

Looking at the installed modules/packages:

linux60-nvidia /usr/
linux60-nvidia /usr/lib/
linux60-nvidia /usr/lib/modules/
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia-drm.ko.xz
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia-modeset.ko.xz
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia-peermem.ko.xz
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia-uvm.ko.xz
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia.ko.xz
linux60-nvidia /usr/share/
linux60-nvidia /usr/share/licenses/
linux60-nvidia /usr/share/licenses/linux60-nvidia/
linux60-nvidia /usr/share/licenses/linux60-nvidia/LICENSE

Not sure what to do at this point, please advise.

See man page for modprobe. Module parameters are passed as separate arguments, not via dot.

Same procedure (1-3 from my post above), this time like advised with sudo modprobe nvidia-modeset output_rounding_fix=0

Then manually started sddm.service and started the DE with startx.

So far, the issue is still there.

I encounter the same problem on

Arch 6.0.12
nvidia 525.60.11-1
xfce 4.18
GeForce GTX 1650
Dell 2408WFP (connected via DP)

In my thread (Video distortion with current linux driver) I provided two youtube videos and pictures.

If my problem is the same then this one, then maybe it’s a good idea
to move the content together. Thanks.

PS The above workaround did not work for me

Still persists on 525.60.11
515 does not have the issue and looks great.

AOC AG241QG - Tried on both DP-4 and DP-2
Pop!_OS 22.04
nvidia 525.60.11

I have noticed on 515 there is no visible change on screen when toggling dithering on/off. on 520 and 525 there is an immediate change in color on the screen.

Please let me know if there is any other info I should collect and if there is a need to post this in a new thread for 525.

1 Like

Same problem here :(

1 Like

Apparently, I can now finally reply. Tried to upgrade to the newest driver today, but the issue persists. So I think that it is safe to say that this bug affects both 520.56.06 and 525.60.11. 515.76 still works correctly tho.

Just wanted to say that this is probably related to the high refresh rate. Because most people who experience it have a high refresh rate monitor and the issue gets progressively worse the higher refresh rate you set. (60hz - basically unnoticeable; 240hz - horrible)

After installing the 525 driver I had a lot of problems with one of my systems. For some reason the driver changes some settings in the Dithering Controls section. With the 515 series I had all the options on Auto which causes no problems at all.

After I installed 525 I had to mess with the settings because I noticed glitches when dragging a window. I had to change Dithering to enabled and Depth on 8 to fix that problem, however when I use 525 I get a lot of color banding. Another problem that I noticed is that if I go to the Information tab the new driver only used 2 lanes instead of 4? Also I believe that the new driver is messing with the color settings. I reverted back to 515.

Ubuntu 22.04 LTS with kernel 5.15
RTX 3050

We were able to duplicate issue locally and working on the fix.
Shall confirm once driver is released publicly with the fix.


Does the new 525.85.05 Release include a fix for this issue?

for those who are wondering the new 525.85.05 driver not fixed the issue

Issue has been root caused and fix will be incorporated in future released driver.


I am very happy to hear that and waiting for next release :)

In 99.9% of all cases, “future release” and “next release” does not mean the same …

@amrits Tell us - in months - how long we have to wait for this fix. And will it fix my problem (mentioned above) as well ?

1 Like

Fix will be available in next upcoming released driver.


I can confirm that this has been fixed in 525.89.02, and everything seems to work fine. Thanks for the fix.

Same here, thanks for the fix :)

I admit, it is better but in the darker places are still pixel artifacts :( I think in previous drivers (before the issue this pixel artifacts wasn’t there)
current driver 525.89.02
Linux-x86_64 (manjaro Gnome version)

3440 x 1440 120Hz GSync Enabled - via Display port
CPU: AMD Ryzen 7 2700X (16) @ 4.000GHz
GPU: NVIDIA GeForce GTX 1050 Ti
Asus PRIME x470PRO

Nvidia setings: Dithering, Mode, Depth on auto [enabled,None,8bpc] [I have more screen shots but can’t add ]: