Color banding and animation issues with 520.56.06


After restarting the PC the colors are awful again, until I start NVIDIA X Server Settings where the screen clears and everything returns to normal…


As a workaround (yep, again), you can:

  • Save your config in ~/.nvidia-settings-rc: NVIDIA X Server Setting > nvidia-settings Configuration > Save Current Configuration
  • Run command nvidia-settings --load-config-only at login

Hope for a real fix soon…

I suspect that changing is to “Temporal” and “6 bpc” is only a temp workaround, as it results in some film noise effect for me.

A different thing to note: I have 2x the same LG Monitors, one connected via HDMI and one via DP. The one connected via DP has the Problem.

The settings of the one connected to HDMI is as follows:

  • Dithering: Auto (Enabled)
  • Mode: Auto (Temporal)
  • Depth: Auto (8 bpc)

Setting those settings for the DP one results in strong Color Banding without visible Grain Effect.

So in theory, the “correct” setting would be 8bpc with Temporal, however it looks like Dithering has been disabled (there is no visible difference between Dithering Disabled and Temporal 8bpc)

Changing it to 6bpc results in a color/brightness shift.

A LG monitors issue?, i have a 32GN600-B and have this issues too with latest drivers 525.60.11 on arch, manjaro and windows 10 too, connected via DP, 165 Hz.

I have the same issue with the latest 525 drivers: AOC 24G2U5/BK monitor connected via DP, Ubuntu 22.10, RTX 2070 SUPER.

1 Like

Same here. Upgrading from 515.86.01 to 525.60.11 dropped my monitor color depth from 8 to 6 bits and there’s ugly banding. The card is an Asus RTX 2080, kernel 5.15.0-56-generic and the screen is an HP Z27 (2560x1440) connected using DisplayPort. Going back to 515 restores the depth.

1 Like

Having the same issue with 525.60.11 on a GTX 1060 3GB. Monitor is an ASUS VG248 connected with DisplayPort.

Hi All,
Request to try loading nvidia-modeset with kernel module parameter ‘output_rounding_fix=0’ and see if the issue still reproduces.

I have filed a bug 3916225 internally for tracking purpose.

Added: nvidia_drm.modeset=1 output_rounding_fix=0 to GRUB_CMDLINE_LINUX_DEFAULT and rebuild it with sudo update-grub
Added: MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm) to /etc/mkinitcpio.confand rebuild it with sudo mkinitcpio -P

The issue still reproduces for me.

It should be nvidia-modeset.output_rounding_fix=0, not just output_rounding_fix=0

Same issue with with nvidia-modeset.output_rounding_fix=0 in GRUB_CMDLINE_LINUX_DEFAULT

Issue still happening with the suggested fix

Can you please try below steps once and share test results again.
1)After booting to console mode, reinstall driver
2)rmmod nvidia_drm nvidia_modeset
3)modprobe nvidia-modeset output_rounding_fix=0

What I did:

  1. Disabled sddm.service → Rebooted to Console
  2. Re-Installed nvidia by firstly removing sudo mhwd -r pci video-nvidia and then reinstalling sudo mhwd -a pci nonfree 0300
  3. Executed sudo rmmod nvidia_drm nvidia_modeset
  4. Executed sudo modprobe nvidia-modeset.output_rounding_fix=0

The command sudo modprobe nvidia-modeset.output_rounding_fix=0 failed with the error: modprobe: FATAL: Module nvidia-modeset.output_rounding_fix=0 not found in directory /lib/modules/6.0.14-1-MANJARO

Looking at the installed modules/packages:

linux60-nvidia /usr/
linux60-nvidia /usr/lib/
linux60-nvidia /usr/lib/modules/
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia-drm.ko.xz
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia-modeset.ko.xz
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia-peermem.ko.xz
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia-uvm.ko.xz
linux60-nvidia /usr/lib/modules/extramodules-6.0-MANJARO/nvidia.ko.xz
linux60-nvidia /usr/share/
linux60-nvidia /usr/share/licenses/
linux60-nvidia /usr/share/licenses/linux60-nvidia/
linux60-nvidia /usr/share/licenses/linux60-nvidia/LICENSE

Not sure what to do at this point, please advise.

See man page for modprobe. Module parameters are passed as separate arguments, not via dot.

Same procedure (1-3 from my post above), this time like advised with sudo modprobe nvidia-modeset output_rounding_fix=0

Then manually started sddm.service and started the DE with startx.

So far, the issue is still there.

I encounter the same problem on

Arch 6.0.12
nvidia 525.60.11-1
xfce 4.18
GeForce GTX 1650
Dell 2408WFP (connected via DP)

In my thread (Video distortion with current linux driver) I provided two youtube videos and pictures.

If my problem is the same then this one, then maybe it’s a good idea
to move the content together. Thanks.

PS The above workaround did not work for me

Still persists on 525.60.11
515 does not have the issue and looks great.

AOC AG241QG - Tried on both DP-4 and DP-2
Pop!_OS 22.04
nvidia 525.60.11

I have noticed on 515 there is no visible change on screen when toggling dithering on/off. on 520 and 525 there is an immediate change in color on the screen.

Please let me know if there is any other info I should collect and if there is a need to post this in a new thread for 525.

1 Like

Same problem here :(

1 Like

Apparently, I can now finally reply. Tried to upgrade to the newest driver today, but the issue persists. So I think that it is safe to say that this bug affects both 520.56.06 and 525.60.11. 515.76 still works correctly tho.

Just wanted to say that this is probably related to the high refresh rate. Because most people who experience it have a high refresh rate monitor and the issue gets progressively worse the higher refresh rate you set. (60hz - basically unnoticeable; 240hz - horrible)

After installing the 525 driver I had a lot of problems with one of my systems. For some reason the driver changes some settings in the Dithering Controls section. With the 515 series I had all the options on Auto which causes no problems at all.

After I installed 525 I had to mess with the settings because I noticed glitches when dragging a window. I had to change Dithering to enabled and Depth on 8 to fix that problem, however when I use 525 I get a lot of color banding. Another problem that I noticed is that if I go to the Information tab the new driver only used 2 lanes instead of 4? Also I believe that the new driver is messing with the color settings. I reverted back to 515.

Ubuntu 22.04 LTS with kernel 5.15
RTX 3050