Combining non-NVidia graphics card and S1070 on Windows7

All our server hardware comes with non-NVidia graphics cards. Combining non-NVidia graphics card with S1070 does not work in Vista and Windows Server 2008 because loading of multiple VDDM drivers is not supported.

Windows 7 and Windows Server 2008 R2 do allow loading of multiple WDDM drivers, so this problem should not exist anymore in theory. I can see that the drivers for both non-NVidia graphics card and C1060 get loaded successfully, but the CUDA still does not work. I am using Windows Server 2008 R2 Beta and v181.71 NVIDIA graphics drivers.

Setting DisplaylessPolicy and LimitVideoPresentSources registry keys suggested in other posts did not make any difference.

Any suggestions on how to make non-NVidia graphics card work with S1070 in Windows Server 2008 R2, like it used to in Windows Server 2003?

I’m interested in getting this to work, too.

Well this isn’t exactly apples to apples, but I run a R700 (4870 X2) and a G92 (9800 GT) on Windows 7 x64 (Release Candidate). Outside of Nvidia’s control panel being completely broken with heterogeneous cards (changing any option crashes the control panel), the setup works fine (ie: CUDA still functions perfectly on the G92). I heard that both cards need to have WDDM 1.1 drivers for this setup to work, although I don’t know why that would be. Sorry if this doesn’t help, but I wanted the general populous to know this kind of setup can work.

Hi jkotas. I have the S1070 on Server 2008 R2. The driver loads correctly and version shown in Device Manager is Tesla C1060 I download and install the cuda driver/sdk/toolkit 2.2 win7 64 bit. I tried to run some sample codes in SDK. Managed to make the build working for the sample project SobolQRNG. but when running the sample binary, I got error:

C:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\projects\SobolQRNG\x64\Debug>SobolQRNG.exe --vectors=2 --dimensions=2
Allocating CPU memory…
Allocating GPU memory…
cudaSafeCall() Runtime API error in file <.\sobol.cpp>, line 155 : no CUDA-capable device is available.

Is this the same as what you’ve observed?

Is Server 2003 OK for the samples to run? Thanks.

I have yet to bang on Server 2008 R2. I imagine I should at some point (when I have time, which probably means “maybe in a few years” :( )…