Command line boot

Is there anyway that i can boot jetson to command line but i can switch to Desktop GUI easily when i want?

One reason I like Fedora is the control over booting different parts of the system or switching between modes on the command line (so for example I can go to text mode with a command, update video drivers, and then restart graphics without rebooting…essentially it is easy to reboot any subsystem with a command). Ubuntu (at least under 14.04) does things a bit differently and to me seems less “unified”, e.g., commands under lightdm are different from commands under a different environment (under systemd mode names are abstracted/unified and do not depend upon which environment is installed).

One possibility is that adding a kernel parameter at boot does the job. In “/boot/extlinux/extlinux.conf”, the APPEND key/value pair can have “text” appended (no pun intended) to the APPEND and boot to text mode.

If you use a serial cosole, you can put more than one boot setup in, such as a copy of the default one, and simply edit that copy to a new LABEL and MENU LABEL (such as “text”), and append “text” to the space-delimited APPEND value of that alternate entry (then select that entry during boot).

It is possible to start the GUI from command line:

sudo service lightdm start

Incidentally, there is a file related to this people may be interested in if they are interested in default boot behavior. See:


…“quiet splash” is the opposite to “text” on a kernel command line.

Stopping graphical mode takes a few seconds extra before the original tty resumes as text mode. While GUI runs, try:

sudo service lightdm stop

Sorry can you be more specific about extlinux.conf. I tried changing APPEND console = … to APPEND text but it doesn’t work.

Just test again and now it worked very well. Thank you so much linuxdev :)

Another problem that i encounter is that after boot to command line, the virtual console doesn’t recognize my external disk drive. Do you have any idea how to fix? Thanks

Regardless of booting to GUI or text mode, there should be no effect on disk drives.

How is the disk connected, e.g., USB, SATA? Is the disk connected before power on? How is the disk partitioned, e.g., fdisk or gdisk? How is it determined that the disk is not recognized, e.g., some particular program? Is the disk a regular hard drive, SSD, so on?

The disk is a regular hard drive, connected by a USB and before power on. When i tried to access to the disk by command line

cd /media/ubuntu/the-location-of-my-disk

then ls it but it doesn’t have anything in there. But after i mount it from /dev/sda5 or start lightdm, then i can access to my disk normally.

This is normal and part of the Linux distribution. Keep in mind that Linux is defined right from the start to allow simultaneous use by thousands of logins of different names at the same time.

Mounting a disk dynamically as a “/media/username” entry requires knowing which user owns the disk. Only in graphical mode does Linux know that the physically connected USB hotplug event is owned by user ubuntu because graphical mode X11 configuration ties ownership of pointer devices, keyboards, USB connectors, and so on to the user logged in. “/media” mount is a per-user operation…changing this would probably require modifying source code since text mode prompts do not define ownership of keyboards, mice, and so on.

If you have a specific use-case you need to make work someone may be able to make suggestions.