Command not found

I’ve just donwloaded and installed a trial version of PGI workstation: the installation (Ubuntu 12.10 x64) returned no errors and I can see the files in the standard directory. I’ve installed the program as root (sudo ./install) and set my license key using the environmental variable (export LM_LICENSE_FILE=path to the .dat folder)

Problem is if I type pgcc (or any other compiler command) the shell returns a “No command found”, how’s it? Do I need to source the commands? Do something else? Did I miss a step?

Hi Victor,

Did you set your PATH environment variable to include the PGI install’s “bin” directory?

For complete instructions on setting up your environment please see: https://www.pgroup.com/resources/docs/19.1/x86/pgi-install-guide/index.htm#install-linux-end-usr-env-settings

By “trial version”, did you mean that you installed the PGI Community Edition? If so, then there’s no need to set LM_LICENSE_FILE since the Community Edition doesn’t use a license daemon.

Hope this helps,
Mat