Compilation Error

My environment is Win8 pro, VS 2012 ultimate 64 bit, CUDA 6.0. While I’m trying to use unified memory, there is always be a fatal error “managed variables are not yet supported for this configuration (compilation mode (32/64)bit and /or target operating system”.
Please tell me what’s wrong? How to fix this?
Many Thanks!

What GPU are you using? What is your compile command line? (The compile command line can usually be directly observed in the VS console at the bottom of the screen. If not, modify your VS settings for more verbose output there. It’s useful for debugging these things.)

The two most obvious possibilities I can think of are either that you are building a Win32 project, which will cause -m 32 to show up in the compile command line, or you are not building for a cc3.0 or newer GPU (gencode and arch flags).

If you are building a Win32 project, switch to a x64 project.
If you are building for a cc1.x or cc2.x GPU, remove those from your project configuration, and add a cc3.0 or newer target.

The requirements for support are spelled out here:

http://docs.nvidia.com/cuda/cuda-c-programming-guide/index.html#um-requirements