Compilation is slow for redhat 6

Hi all,

I have a cluster on which I have installed pgi 11.10 that uses a multi user license on a different server. Since upgrading to redhat 6 compilation times have gone from roughly 15 minutes to 8-10 hours. I don’t believe it’s a network issues since nothing with the network has changed and other servers on the same subnet work just fine. I even reverted a node on the cluster back to redhat 5 and it worked significantly faster.

In reading some other threads I am posting my test app with -v -time flags. There is only one pause and that’s indicated below.

Thanks in advance for the help.

[arnoldm@head ~]$ cat test.c

int main (int argc, char * argv)

[arnoldm@head ~]$ pgcc -time -v test.c

/opt/pgi/linux86-64/11.10/bin/pgc test.c -opt 1 -x 119 0xa10000 -x 122 0x40 -x 123 0x1000 -x 127 4 -x 127 17 -x 19 0x400000 -x 28 0x40000 -x 120 0x10000000 -x 70 0x8000 -x 122 1 -x 125 0x20000 -quad -x 59 4 -x 59 4 -tp nehalem -x 120 0x1000 -astype 0 -stdinc /opt/pgi/linux86-64/11.10/include:/usr/local/include:/usr/lib/gcc/x86_64-redhat-linux/4.4.5/include:/usr/lib/gcc/x86_64-redhat-linux/4.4.5/include:/usr/include -def unix -def __unix -def unix -def linux -def __linux -def linux -def __NO_MATH_INLINES -def x86_64 -def LONG_MAX=9223372036854775807L -def ‘SIZE_TYPE=unsigned long int’ -def ‘PTRDIFF_TYPE=long int’ -def __THROW= -def extension= -def amd64 -def SSE -def MMX -def SSE2 -def SSE3 -def SSSE3 -predicate ‘#machine(x86_64) #lint(off) #system(posix) #cpu(x86_64)’ -cmdline ‘+pgcc test.c -time -v’ -x 123 0x80000000 -x 123 4 -x 2 0x400 -x 119 0x20 -def __pgnu_vsn=40405 -alwaysinline /opt/pgi/linux86-64/11.10/lib/ 4 -x 120 0x200000 -x 0 1 -asm /tmp/pgccCBWcuITViOr3.s

######! ~10s pause here ########

PGC-I-0222-Redundant definition for symbol __THROW (/usr/include/sys/cdefs.h: 63)
PGC-I-0222-Redundant definition for symbol extension (/usr/include/sys/cdefs.h: 339)
Timing stats:
init 50 millisecs 100%
Total time 50 millisecs
PGC/x86-64 Linux 11.10-0: compilation completed with informational messages

/usr/bin/as /tmp/pgccCBWcuITViOr3.s -o /tmp/pgcc8BWc00zlnAuS.o

/usr/bin/ld /usr/lib64/crt1.o /usr/lib64/crti.o /opt/pgi/linux86-64/11.10/lib/trace_init.o /usr/lib/gcc/x86_64-redhat-linux/4.4.5/crtbegin.o /opt/pgi/linux86-64/11.10/lib/initmp.o -m elf_x86_64 -dynamic-linker /lib64/ /opt/pgi/linux86-64/11.10/lib/pgi.ld -L/opt/pgi/linux86-64/11.10/lib -L/usr/lib64 -L/usr/lib/gcc/x86_64-redhat-linux/4.4.5 /tmp/pgcc8BWc00zlnAuS.o -rpath /opt/pgi/linux86-64/11.10/lib /opt/pgi/linux86-64/11.10/lib/nonuma.o -lpgmp -lpthread -lnspgc -lpgc -lm -lgcc -lc -lgcc /usr/lib/gcc/x86_64-redhat-linux/4.4.5/crtend.o /usr/lib64/crtn.o
Unlinking /tmp/pgccCBWcuITViOr3.s
Unlinking /tmp/pgcc8BWc00zlnAuS.o

Hi arnoldm,

It’s not the compilation, but rather the new system has a slow connection to the license server. Please contact PGI Customer Service ( since they have a check list of things for you to try which will help pinpoint the reason for the slow connection.

  • Mat

How come the same system with redhat 5 worked fine. Or a non redhat 6 system inside the cluster (using the head node as a gateway) works just fine. Everything worked fine until I upgraded to redhat 6. I will email them anyway to see if it helps.