compile error using CUDA 2.0 'cudafe' died due to signal 11

I have just installed CUDA 2.0 driver, toolkit, and sdk on fedora 8, and then tried to compile my codes that worked on CUDA 1.1. Unfortunately, I have the following compile error:

nvcc error: ‘cudafe’ died due to signal 11 (Invalid memory reference)

Could anybody please tell me what is likely to cause that error?

Nicky

Its potentially a bug in cudafe. Can you post a test app which reproduces this behavior, along with the exact command that triggers it?

Also, please post the output from running “nvcc -V” and an nvidia-bug-report.log.

thanks,
Lonni

Hi

Here’s a small test app that produces the behaviour on my system:

template<unsigned int N>

__global__ void

moo( float[N] ) {

}

int main() {

  float boo[3] = {1.0, 2.0, 3.0};

  moo<3><<<dim3(2,1),dim3(16,1)>>>(boo);

  return 0;

}

output:

[font=“Courier”]modesty ~ $ nvcc -V

nvcc: NVIDIA ® Cuda compiler driver

Copyright © 2005-2007 NVIDIA Corporation

Built on Tue_Jun_10_05:42:45_PDT_2008

Cuda compilation tools, release 1.1, V0.2.1221

modesty ~ $ nvcc reproduce.cu

nvcc error : ‘cudafe’ died due to signal 11 (Invalid memory reference)

modesty ~ $[/font]

Best,

Chris

Thanks, I’m able to replicate this, and have opened bug 439534 to have it investigated further. I’ll let you know if there are any immediate solutions or workarounds.

This should be fixed in the next release.

Heya,

I have the same problem - i publicate it on that forum:

http://www.gpgpu.org/forums/viewtopic.php?t=5396

if some one know what it’s wrong i be glad