Compiling in emulation mode


I have a short little CUDA program I put together that works perfectly on my laptop where I have a compatible GPU, but unfortunately I seem to have hit a stumbling block with running it on a machine without a GPU.
Based on the instructions, I don’t see why this won’t work. I have the toolkit installed properly, I set my PATH and LD_LIBRARY_PATH, but all the emu programs error out e.g.:
cudaSafeCall() Runtime API error in file <>, line 59 : feature is not yet implemented.


cutilCheckMsg() CUTIL CUDA error: Kernel execution failed in file <>, line 117 : feature is not yet implemented.
Total number of bank conflicts: 0

I did a make cobber beforehand, and still no dice. Is the SDK somehow hardwired so that if you compile it on a machine with a GPU and then copy the SDK directory to a new machine without one this happens? I changed the path the toolkit in, and that was the only machine specific thing I could find.
The machine it won’t work on is a 32 bit Fedora core 9 install ( The machine it does work on it a Ubuntu 8.04 x86_64 setup.
I tried compiling and running the emurelease examples on the machine with a GPU, and it seems to work just fine, albeit a lot slower than the GPU enabled binaries.

Does the nvidia driver still need to be installed for the emu build? The instructions seemed to indicate no. I feel like I’m missing some critical step here.