Compiling kernel on new release

Tried to compile the kernel on the new release today. Things went pretty good initially but the old error on the 32 bit clock stuff showed up again. But the old patch for that is already in the code. So no idea why its failing now. Shouldn’t that vdso32 stuff be out of the kernel now that its full 64 bit all the way? I thought that was just in there to allow the mixed 64 bit kernel 32 bit filesystem. Not present in the kernel source you download from ubuntu so wondering if its even supposed to get compiled now. If this is the case what do you edit to get it out of the compile?

I don’t know if it would be possible to change the 32-bit compile of vdso32. One thing which gets in the way is that regardless of whether you want to run 32-bit code the CPUs support 32-bit. There are some kernel options regarding support for compatibility mode 32-bit…perhaps if options to support compatibility in kernel are disabled then vdso32 would not attempt compile (I have not experimented with this, it’s just a thought on the topic).

If you’re referring to the problem I think you are referring to, I solved it using this post:
https://devtalk.nvidia.com/default/topic/914941/jetson-tx1/custom-kernel-compilations/post/4804526/#4804526

Specifically I just added the -marm flag to ccflags-y:

That doesn’t work with the new OS 64 bit version. Do you need to have a 32 bit compiler and cross compiler env set up to compile the kernel on the new version 16.04 of L4T? From what I understood on this version you could compile the kernel just like on any other linux system. No cross compiling required. I’ll look into nuking 32 bit compatibility.

kangalow posted a(nother) great article on this: http://jetsonhacks.com/2016/09/28/build-tx1-kernel-and-modules-nvidia-jetson-tx1/