Compute capability is 1.1, suitable cuda version?

Hi, I’m new to cuda programing. I have GeForce 9500 Gt installed in my desktop. When I installed cuda 7.0 it said that my gpu is not compatible, but GeForce 9500 Gt has 35 cuda cores and a compute capability of 1.1. I would like to learn learn more. Please help me … Do you think installing a lesser version will solve the problem? if so what is the cuda version I should install? Please help me …

–Thank you in advance …

The CUDA 7.0 toolkit and drivers don’t support compute architectures 1.0 to 1.3 anymore.
See chapter 3.0 here: http://developer.download.nvidia.com/compute/cuda/7_0/Prod/doc/CUDA_Toolkit_Release_Notes.pdf

The latest Windows driver for GeForce 9500 GT is http://www.nvidia.com/download/driverResults.aspx/82467/en-us and that site says “CUDA Toolkit: 6.5”, so download and install that Toolkit from the CUDA download archive.
Do a custom install and deselect the display driver installation to keep your current installed display driver if it’s the newest one.

Thank you …

I’m using ubuntu 14.04, this is the platform where I face this problem. Will installing “CUDA Toolkit: 6.5” solve the problem ?

When I install “CUDA Toolkit: 7.0” the driver did not work properly, so I installed the latest driver using the run file. Will installing driver separately using a .run file cause any malfunction?

And how to remove all “CUDA Toolkit: 7.0” related files so that I can install a clean version of “CUDA Toolkit: 6.5”?

–Thank you …

Yes, CUDA toolkit 6.5 would be the latest one with support for your GPU on any OS.

The display driver contained inside CUDA toolkits is only needed when the toolkit is brand new and no public driver with support for that CUDA version has been released, yet.
As soon as an official display driver release is available which supports a specific CUDA version you require, installing that newer display driver is actually recommended.
As said, if you have a display driver version installed which already supports CUDA 6.5, keep that and do not install the older display driver from the CUDA toolkit.

I’m not using Linux. Please refer to the documentation about how to install or uninstall a CUDA Toolkit: http://docs.nvidia.com/cuda/cuda-getting-started-guide-for-linux/index.html

Thank you …

After little struggle I managed to install CUDA Toolkit 6.5. And I tried a little program and it’s working fine.

I used run file to install in tty mode and it’s working fine.

–Thanks again …

Solved problem?

Hi, I’m having a problem with this. I am delighted to be of assistance. How do you know this problem properly?

21:18:55:543 ec4
21:18:55:549 ec4 ЙНННННННННННННННННННННННННННННННННННННННННННННННННННННННННННННННН»
21:18:55:558 ec4 є Claymore’s Dual ETH + DCR/SC/LBC/PASC GPU Miner v9.8 є
21:18:55:564 ec4 ИННННННННННННННННННННННННННННННННННННННННННННННННННННННННННННННННј
21:18:55:576 ec4
21:18:55:781 ec4 ETH: 1 pool is specified
21:18:55:790 ec4 Main Ethereum pool is eu1.ethermine.org:4444
21:18:55:795 ec4 DCR: 0 pool is specified
21:18:56:291 ec4 AMD OpenCL platform not found
21:18:56:688 ec4 cudaGetDeviceCount failed (30, unknown error), probably no CUDA devices
21:18:56:698 ec4 No NVIDIA CUDA GPUs detected.
21:18:56:709 ec4 No AMD OPENCL or NVIDIA CUDA GPUs found, exit