ComputerVision Installation Failed on Target

Can someone help me with this? I have a JetsonTX2 and trying to install SDK components but the Computer Vision (OpenCV, VisionWorks & VPI on Target) keeps on failing.

I believe that the OpenCV is having an error and the others follow. Below is the error message.

14:51:35 INFO: OpenCV on Target - target: *begin sudo apt-get install -y python-dev python-numpy
python-py python-pytest, 5
14:51:35 INFO: OpenCV on Target - target: Reading package lists... 0% Reading package lists... 100%
Reading package lists... Done
14:51:35 INFO: OpenCV on Target - target: Building dependency tree... 0% Building dependency
tree... 0% Building dependency tree... 50% Building dependency tree... 50% Building dependency
tree
14:51:35 INFO: OpenCV on Target - target: Reading state information... 0% Reading state
information... 0% Reading state information... Done
14:51:36 INFO: OpenCV on Target - target: Some packages could not be installed. This may mean
that you have
14:51:36 INFO: OpenCV on Target - target: requested an impossible situation or if you are using the
unstable
14:51:36 INFO: OpenCV on Target - target: distribution that some required packages have not yet
been created
14:51:36 INFO: OpenCV on Target - target: or been moved out of Incoming.
14:51:36 INFO: OpenCV on Target - target: The following information may help to resolve the
situation:
14:51:36 INFO: OpenCV on Target - target: The following packages have unmet dependencies:
14:51:36 INFO: OpenCV on Target - target: python-dev : Depends: libpython-dev (= 2.7.15~rc1-1) but
it is not going to be installed
14:51:36 INFO: OpenCV on Target - target: Depends: python2.7-dev (>= 2.7.15~rc1-1~) but it is not
going to be installed
14:51:36 ERROR: OpenCV on Target - target: E: Unable to correct problems, you have held broken
packages.
14:51:36 ERROR: OpenCV on Target - target: Error: safe apt install failed: sudo apt-get install -y
python-dev python-numpy python-py python-pytest, exit code: 100, retry number: 1
14:51:36 INFO: OpenCV on Target - target: will sleep 10 seconds before next attempt
14:51:46 INFO: OpenCV on Target - target: Reading package lists... 0% Reading package lists... 100%
Reading package lists... Done
14:51:47 INFO: OpenCV on Target - target: Building dependency tree... 0% Building dependency
tree... 0% Building dependency tree... 50% Building dependency tree... 50% Building dependency
tree
14:51:47 INFO: OpenCV on Target - target: Reading state information... 0% Reading state
information... 0% Reading state information... Done
14:51:47 INFO: OpenCV on Target - target: Some packages could not be installed. This may mean
that you have
14:51:47 INFO: OpenCV on Target - target: requested an impossible situation or if you are using the
unstable
14:51:47 INFO: OpenCV on Target - target: distribution that some required packages have not yet
been created
14:51:47 INFO: OpenCV on Target - target: or been moved out of Incoming.
14:51:47 INFO: OpenCV on Target - target: The following information may help to resolve the
situation:
14:51:47 INFO: OpenCV on Target - target: The following packages have unmet dependencies:
14:51:47 INFO: OpenCV on Target - target: python-dev : Depends: libpython-dev (= 2.7.15~rc1-1) but
it is not going to be installed
14:51:47 INFO: OpenCV on Target - target: Depends: python2.7-dev (>= 2.7.15~rc1-1~) but it is not
going to be installed
14:51:47 ERROR: OpenCV on Target - target: E: Unable to correct problems, you have held broken
packages.
14:51:47 ERROR: OpenCV on Target - target: Error: safe apt install failed: sudo apt-get install -y
python-dev python-numpy python-py python-pytest, exit code: 100, retry number: 2
14:51:47 INFO: OpenCV on Target - target: will sleep 20 seconds before next attempt
14:52:07 INFO: OpenCV on Target - target: Reading package lists... 0% Reading package lists... 100%
Reading package lists... Done
14:52:08 INFO: OpenCV on Target - target: Building dependency tree... 0% Building dependency
tree... 0% Building dependency tree... 50% Building dependency tree... 50% Building dependency
tree
14:52:08 INFO: OpenCV on Target - target: Reading state information... 0% Reading state
information... 0% Reading state information... Done
14:52:08 INFO: OpenCV on Target - target: Some packages could not be installed. This may mean
that you have
14:52:08 INFO: OpenCV on Target - target: requested an impossible situation or if you are using the
unstable
14:52:08 INFO: OpenCV on Target - target: distribution that some required packages have not yet
been created
14:52:08 INFO: OpenCV on Target - target: or been moved out of Incoming.
14:52:08 INFO: OpenCV on Target - target: The following information may help to resolve the
situation:
14:52:08 INFO: OpenCV on Target - target: The following packages have unmet dependencies:
14:52:08 INFO: OpenCV on Target - target: python-dev : Depends: libpython-dev (= 2.7.15~rc1-1) but
it is not going to be installed
14:52:08 INFO: OpenCV on Target - target: Depends: python2.7-dev (>= 2.7.15~rc1-1~) but it is not
going to be installed
14:52:08 ERROR: OpenCV on Target - target: E: Unable to correct problems, you have held broken
packages.
14:52:08 ERROR: OpenCV on Target - target: Unhandled error when running sudo apt-get install -y
python-dev python-numpy python-py python-pytest: E: Unable to correct problems, you have held
broken packages.;
14:52:08 INFO: OpenCV on Target - target: [ Package PreInstall Finished with Error ]
14:52:08 INFO: OpenCV on Target - target: [ NV_L4T_OPENCV_TARGET_POST_INSTALL_COMP
Install took 39s ]
14:52:08 ERROR: OpenCV on Target - target: command terminated with error
14:52:08 SUMMARY: OpenCV on Target - target: First Error: safe_apt_install failed to run.

Hi,

How do you install these components?
Using SDK manager or apt?

Thanks.

I’m using SDK Manager. I’ve tried couple version (older versions) and the only error I was getting was on ComputerVision (OpenCV specifically) and the other components of ComputerVision is failing as well because of dependency error.

I even tried apt update and upgrade but still the same. I even tried installing OpenCV manually but still giving me dependency errors



Hi,

Do you also flash the device with the same JetPack version?
Or just install the components?

Thanks.

Yes, I flash the device with the same JetPack version then install SDK components with it.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Sorry for the late response, is this still an issue to support? Thanks