Config for NvDCF enable-past-frame:1 in test2 failed: "Unknown key 'enable-past-frame' for group [tracker]"

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version 5.0
• TensorRT Version 7.0
• NVIDIA GPU Driver Version (valid for GPU only) NVIDIA-Linux-x86_64-450.80.02
• Issue Type( questions, new requirements, bugs) bugs
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

Hello,When I run the command: ./deepstream-test2-app sample_720p.h264
I got the log as below:

With tracker
Unknown key ‘enable-past-frame’ for group [tracker]Now playing: sample_720p.h264
gstnvtracker: Loading low-level lib at /opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_nvdcf.so
gstnvtracker: Batch processing is ON
gstnvtracker: Past frame output is OFF
[NvDCF] Initialized
WARNING: …/nvdsinfer/nvdsinfer_func_utils.cpp:36 [TRT]: Current optimization profile is: 0. Please ensure there are no enqueued operations pending in this context prior to switching profiles
0:00:04.534692058 4852 0x5588b56b98c0 INFO nvinfer gstnvinfer.cpp:619:gst_nvinfer_logger: NvDsInferContext[UID 1]: Info from NvDsInferContextImpl::deserializeEngineAndBackend() <nvdsinfer_context_impl.cpp:1701> [UID = 1]: deserialized trt engine from :/opt/nvidia/deepstream/deepstream-5.0/samples/models/Primary_Detector/resnet10.caffemodel_b1_gpu0_int8.engine
INFO: …/nvdsinfer/nvdsinfer_model_builder.cpp:685 [Implicit Engine Info]: layers num: 3
0 INPUT kFLOAT input_1 3x368x640
1 OUTPUT kFLOAT conv2d_bbox 16x23x40
2 OUTPUT kFLOAT conv2d_cov/Sigmoid 4x23x40

0:00:04.534811871 4852 0x5588b56b98c0 INFO nvinfer gstnvinfer.cpp:619:gst_nvinfer_logger: NvDsInferContext[UID 1]: Info from NvDsInferContextImpl::generateBackendContext() <nvdsinfer_context_impl.cpp:1805> [UID = 1]: Use deserialized engine model: /opt/nvidia/deepstream/deepstream-5.0/samples/models/Primary_Detector/resnet10.caffemodel_b1_gpu0_int8.engine
0:00:04.536298154 4852 0x5588b56b98c0 INFO nvinfer gstnvinfer_impl.cpp:313:notifyLoadModelStatus: [UID 1]: Load new model:dstest2_pgie_config.txt sucessfully
Running…

I’ve configed the enable-past-frame=1 in the file /opt/nvidia/deepstream/deepstream/sources/apps/sample_apps/deepstream-test2/dstest2_tracker_config.txt
Here is my dstest2_tracker_config.txt

[tracker] tracker-width=960 tracker-height=544 gpu-id=0 #ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_klt.so ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_nvdcf.so ll-config-file=tracker_config.yml enable-batch-process=1 enable-past-frame=1

and I also modified useBufferedOutput: 1 in \opt\nvidia\deepstream\deepstream-5.0\samples\configs\deepstream-app\tracker_config.yml

So, Is “Unknown key ‘enable-past-frame’ for group [tracker]” a bug or my config has something wrong?

Hey customer,
Yes, currently test2 cannot parse ‘enable-past-frame’.
2 solutions to fix it:
1.you can follow the deepstream_test2_app.c -> set_tracker_properties to parse it and the set the tracker property if you are using test2 sample
2.you can use deepstream-app which can parse it correctly.

@bcao Thank you, I’ll try it out.