Configure CUDA 5.5 for Visual Studio Studio Express 2012

Hello, currently I am experiencing some troubles to configure the CUDA 5.5 for VS Express 2012.
I followed few guides I found through the net, but did not completely work.

What I’ve did:

  1. Installed VS Express 2012
  2. Installed CUDA: the Nsight did not install the features for VS 2012 (not sure if it should or not install since I am using the Express one)
  3. in VS changed the .cu association for c/c++
  4. Created a Win32 C++ project (also, I don’t know why, but when creating with Empty project it does not compile, it always says that could not find the .exe file)
  5. Project -> Build Costumizations -> Find Existing -> Toolkit location\extras\visual_studio_integration\MSBuildExtensions\CUDA 5.5.targets and added to the project (in the guides I’ve found where saying to edit the .target and .props files, for the 5.0 version, but was confusing since there were some repeated names and was for 5.0)
  6. Project -> Properties -> Configuration Properties -> VC++ Directories added in Include Directories (CUDA_PATH)\include[/i] and in Library Directories [i](CUDA_PATH)\lib\x64 (the guides on the net used CUDA_INC_PATH and CUDA_LIB_PATH, but they were not automatically added to the environment variables
  7. Project -> Properties -> Configuration Properties -> CUDA C/C++ -> Common -> Target Machine Platform -> 64-bit

after all this, when I compile and debug I get the following error:
Error 1 error LNK2019: unresolved external symbol _cudaFree@4 referenced in function _main [project directory]\test2\test2.cu.obj test2
and many others referring to CUDA functions.

what I am doing wrong?

also, what includes I should use for not having __syncthreads() and <<< highlighted?, currently I have cuda_runtime.h and device_launch_parameters.h

thank you and sorry to bother you

You probably figured it out already, but simply add the CUDA libraries you’re using… cuda.lib and cudart.lib to the Additional libraries field under the linker options.

http://www.youtube.com/watch?v=rbHURDt2dcQ