Configuring a Quadro FX 580 for BricsCAD - lines are often faint

1st apologies if this is the wrong forum for this. I posted in another forum, and someone suggested this would be a better place, since you are used to the issues that confront programmers and the interface to the video card.

I am a CAD user, and am having difficulties with my CAD program when I try to use it on a system with a Quadro FX 580 in a used Dell desktop system that I recently was given by my company. I am hoping to use it with a CAD program called BricsCAD. However a large percentage of the model views have lines for the objects that are faded out. Pastel would be another way to describe the colors. When I view the same DWG file on my laptop, they all show properly. The problem is enough of an issue that I cannot use this computer to do CAD work.

It seems the more complex objects are more prone to the issue showing up. I have tried different versions of the drivers, and variations on the settings in the Advanced 3D settings window, without any changes. I have also tried each of the pre-set parameters that are in the driver, though none seem directly designed for a CAD program, which surprised me.

Any suggestions about what may be causing my problems or how to trouble shoot it?


Hard to tell from the description. A screenshot of the problem would be helpful.
(Hover over the paper clip icon in the top right corner of your submitted post to attach files.)

Could that be line antialiasing gone too thin?
In that case, search for an option inside the CAD program to turn off antialiasing.
Or if you forced some antialiasing mode in the NVIDIA control panel switch them to no antialiasing.

What’s the GPU in your laptop?

[edit; before you put any more effort into this, look at my next message. The problem may be resolved -Joe]

Here are some pictures of the screen illustrating the issue. The image of the faint-line view is actually much bolder than it appears to my eye. It is hard to get the exposure and saturation correct. But, attached are two images that illustrate the point.

I do not have settings for the video card in my CAD program. I can only control what type of rendering a view shows. Today when I opened the files, they actually all showed correctly for the first time. The only difference I can think of since yesterday is that I installed Blender, and just opened it. So, the blender program may have made some changes to the video settings. I was able to get my CAD program to revert back to the faint lines by changing the render style to not remove obscured lines.

I did try messing with anti-aliasing in the Nvidia settings window, but I could not see any changes based on my various inputs.

The laptop has an integrated Intel graphics, so it is puzzling why the display looks better there. But, the performance becomes totally unusable when ever I turn on the shaded views.

Thank you for looking at this.


I just tried again to turn the antialiasing off. Now I can’t get the problem to manifest itself, even if I turn antialiasing back on. My past efforts were certainly properly described as floundering, since it has been many years since I played with Nvidia drivers. So, it is possible that my prior efforts were just not being properly applied. But, the inconsistent nature of the problem makes it hard to track down a specific cause.

So, at least for now, consider the problem solved.