Confusing problem with backlight on Ubuntu 16


Unity shows control while I press the Fn+Increase/Descrese brightness, but nothing happens. In console brightness doesn’t work too while X server is running.

Checked solutions

I have tried ALL POSSIBLE solutions of this problem in google and nothing works:

  1. write acpi_backlight in grub
  2. reinstall drivers with apt purge nvidia*
  3. write "EnableBrightnessControl=1" in xorg.conf
  4. install nvidia-375.66, nvidia-378.13, 381.22, 384.47
  5. "xbacklight -set X" doesn't work
  6. changing /sys/class/backlight/brightness
  7. update linux kernel from 4.8 to 4.10
  8. xrandr --output DP-0 --brightness 0.5 --- bad solution
  9. replace EDID from old matrix (it breaks everything)
  10. setpci -v -H1 -s 00:01.0 3e.W=0 and then change backlight using Fn+keys

My system and situation

I used N173HHE-G32 display matrix in my laptop before and everything was OK. But today I’ve replaced it to B173HAN01.2 and this problem has started. On Windows 10 I’ve solved it by reinstalling drivers on nvidia-376 from official MSI website.

So, I can see the next sequence: at laptop start brightness is maximum, then it is minimum (and working) while “initramfs …” text is showing in console. And after X server starts brightness is maximum (broken) again. When X server stops brightness is working again!

System: MSI GT73VR 7RF, Ubuntu 16.04.2 LTS, NVidia GeForce GTX1080, B173HAN01.2 display matrix

uname -a 
4.8.0-58-generic #63~16.04.1-Ubuntu SMP Mon Jun 26 18:08:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

lspci | grep -i vga
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1be0 (rev a1)


But when I use nvidia-378 it WORKS! Unfortunately 378 has a critical bugs after suspend mode in Unity interface :(((

Please help, my eyes are in blood (it’s very bright for them) and I don’t know what to do…