Connect linux ptpd to ConnectX-4 port

Note: I verified that the linux ptpd worked correctly with an Intel ethernet port on the same machine and configured for the same subnet, it’s not an issue of not being connected to a subnet with a PTP master.

******* The question is if I have missed some configuration of the port that I could do with a linux utility or Mellanox/Nvidia utility.

Trying to follow instructions for this as described here:
https://mymellanox.force.com/mellanoxcommunity/s/article/running-ptpd-with-connectx-4

That includes steps to check the status of the interface including the capabilities.

From the instructions:
2. Make sure that PTP is enabled on the desired interface (in this example, cx4p1):

ethtool -T cx4p1

Time stamping parameters for cx4p2:

Capabilities:
hardware-transmit (SOF_TIMESTAMPING_TX_HARDWARE)
software-transmit (SOF_TIMESTAMPING_TX_SOFTWARE)
hardware-receive (SOF_TIMESTAMPING_RX_HARDWARE)
software-receive (SOF_TIMESTAMPING_RX_SOFTWARE)
software-system-clock (SOF_TIMESTAMPING_SOFTWARE)
hardware-raw-clock (SOF_TIMESTAMPING_RAW_HARDWARE)
PTP Hardware Clock: 0
Hardware Transmit Timestamp Modes:
off (HWTSTAMP_TX_OFF)
on (HWTSTAMP_TX_ON)
Hardware Receive Filter Modes:
none (HWTSTAMP_FILTER_NONE)
all (HWTSTAMP_FILTER_ALL)

***** On my system, the output is same except the Capabilities list is missing:
software-transmit (SOF_TIMESTAMPING_TX_SOFTWARE)
software-receive (SOF_TIMESTAMPING_RX_SOFTWARE)
software-system-clock (SOF_TIMESTAMPING_SOFTWARE)

Here’s the result from my system:

ethtool -T enp216s0f1

Time stamping parameters for enp216s0f1:
Capabilities:
hardware-transmit (SOF_TIMESTAMPING_TX_HARDWARE)
hardware-receive (SOF_TIMESTAMPING_RX_HARDWARE)
hardware-raw-clock (SOF_TIMESTAMPING_RAW_HARDWARE)
PTP Hardware Clock: 5
Hardware Transmit Timestamp Modes:
off (HWTSTAMP_TX_OFF)
on (HWTSTAMP_TX_ON)
Hardware Receive Filter Modes:
none (HWTSTAMP_FILTER_NONE)
all (HWTSTAMP_FILTER_ALL)


The next step of verification doesn’t report any PTP packets:

  1. Make sure that the GM clock is configured on the same subnet, and that the host is receiving PTP packets:

sudo tcpdump -i cx4p1 | grep -i ptp

************ Is there a way to enable the missing capabilities and is that all that’s missing to get this to work.
Thanks.

You can refer below config PTP HW clock on NIC,

https://support.mellanox.com/s/article/running-ptpd-with-connectx-4

In the mean time, PTP need MLX switch configuration to support,

https://docs.nvidia.com/networking/pages/viewpage.action?pageId=34261863

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.