Connect Ultrasonic sensor to Jetson NX

I have a Jetson Xavier Nx board. For my work, I need to interface the ultrasonic sensor (AJ-SR04M) to my board.
Here are the connections.

  1. 5V - 5V
  2. GND -GND
  3. TRIG- Pin 12
  4. ECHO - Pin 16

But, I am not getting any echo signals from the sensor.

The same sensor, I interfaced with Raspberry Pi and able to receive the signal. But, Jetson NX is not able to receive it.

Any suggestions might help. Thanks in advance.

What’s the type of TRIG/ECHO pin? GPIO?
You may need to configure them as GPIO pin if necessary.

Its GPIO only and I used Jetson.GPIO library. But its not working.

Have a try to configure the pin as GPIO

I tried it. Still not working.

First challenge is to get the distance from sensor and next challenge is multiple sensors.

Actually, I want to connect eight ultrasonic sensors to Jetson NX and want to do some Sensor Fusion on that.

will it be possible?

Can you please give me some suggestions on single sensor data acquisition and multiple interface?

I think you should check if the GPIO is functional, maybe probe the GPIO to check if it can be control or not.

Okay. I will try that.

If ultrasonic sensor works, will it be possible to connect eight sensors with common TRIG and common ECHO?

Hi,
I tried configuring the GPIO but still ultrasonic sensor is not working.
I checked the voltage on those pins and it shows 0V. Seems to be GPIO is not sending output signal.

I don’t know what else to do. Please help me on this.