Connecting PCIe sound card to Jetson TX2 Developer Kit

Hello everyone,

I’m trying to connect PCIe sound card to Jetson TX2 Developer Kit. I cannot see card in any GUI application.
As far as I can tell, sound driver is missing. This is the output of “lspci -v” command:

01:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 01) (prog-if 00 [Normal decode])
	Flags: fast devsel, IRQ 379
	Bus: primary=01, secondary=02, subordinate=02, sec-latency=0
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [78] Power Management version 3
	Capabilities: [80] Express PCI-Express to PCI/PCI-X Bridge, MSI 00
	Capabilities: [c0] Subsystem: Device 0000:0000
	Capabilities: [100] Virtual Channel

02:00.0 Multimedia audio controller: C-Media Electronics Inc CMI8738/CMI8768 PCI Audio (rev 10)
	Subsystem: C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
	Flags: stepping, medium devsel, IRQ 379
	I/O ports at <ignored> [disabled]
	Capabilities: [c0] Power Management version 2

I did not find any package with additional kernel modules with apt search. Does this mean I will have to compile kernel to be able to install the card?

These modules are available on the default Ubuntu 16.04 system:

nvidia@tegra-ubuntu:/$ ls /lib/modules/4.4.15-tegra/kernel/sound/
nvidia@tegra-ubuntu:/$ ls /lib/modules/4.4.15-tegra/kernel/sound/usb/
snd-usb-audio.ko  snd-usbmidi-lib.ko

Thank you in advance.

I have a C-Media based USB headset which works without addition. In the case of PCIe, perhaps the verbose version will mention something about drivers. What do you get from:

<s><b>sudo</b> lspci -vvv -d 02:00.0</s>
<b>sudo</b> lspci -vvv -<b>s</b> 02:00.0

Thanks for your comment. I get:

lspci: -d: Invalid device ID

Oops…should be “-s” for slot, I used “-d”, which is device:

sudo lspci -s 02:00.0 -vvv