Connector addon doesn't load with the message "The file is an outdated Add-On that cannot be used with this ARCHICAD version"

Hello, when adding/enabling the connector addon on Archicad it fails with the following message

The file is an outdated Add-On that cannot be used with this ARCHICAD version

So far I’ve tried the following:

  • Three different Archicad builds (23.5005 BRA, 25.4013 BRA, 25.4013 INT)
  • Loading the omniverse addon both from its default folder (inside %localappdata%\ov\pkg) and by copying the apx file into Archicad’s addon folder.
  • Two different computers: one virtual (domain joined Windows 10 Enterprise VDA running w/o admin rights) ; and one physical (non-domain joined Windows 10 Pro PC running as local admin)
  • I’ve checked that there were no missing dependencies on the apx using dependency walker.

The result was the same on all of them. Does the addon only works in a specific Archicad version/build (and which one) or is there another issue?

Additional data:

  • Connector version :103.1.93

VDA specs:

  • Driver version: 511.65
  • vGPU model: Nvidia A40 on a 8Q profile

Physical machine specs

  • Driver version: 511.79
  • GPU model: RTX 2080

Thank you,
Gustavo Rocha

Hello @gustavo.rocha! Welcome to the Community! I informed the development team about your issue.

To help identify the issue, could you attached the log files for both the VM and Physical Machine? You can find them here: C:\Users\<USERNAME>\Documents\Omniverse\archiCAD

Hello,

I don’t have access to the physical machine right now (I’ll only go back to the office a couple of weeks from now), but on the virtual machine there is no Omniverse folder within the Documents folder, as per the following image (explorer is already configured to show hidden files and folders):

The connector was installed on the local app data folder of the same user:

By the way, I noticed that there is an ArchicadOmniSetup application in there, but when opened it lists neither the connector nor Archicad as installed:
omniSetup

On the Omniverse Launcher it does list the connector as installed:

Both Archicad 23 (BRA 5005) and Archicad 25 (BRA 4013) are installed and running properly on the virtual machine.

I can try to install it on my home PC before getting back to the office to check whether the same happens on a physical machine, but the caveat would be that I don’t have an officially supported GPU (it’s a GTX 1080 Ti).

Edit: a co-worker tried it out on their local PC (with an RTX2060 and Archicad 25 BRA 4103) and the end result was the same. No Omniverse folder inside Documents either.

Here’s the print of the error message on Archicad addon manager:
Archicad 25 BRA (in Portuguese):

Archicad 25 INT (in English):

@gustavo.rocha The version that you installed only supports Archicad 24. However on March 31 a new version of the Archicad Omniverse Connector became available the launcher, and will support both Archicad 24 and Archicad 25.
The new connector version is 104.1.130. Please install this and try again. There is no need to move files, and doing so may break the install. Please let us know if this fixes the issue.

Hello, the updated version did work on Archicad 25, thank you very much.

As a side note, the installation required admin rights on the machine (apparently because of a registry change).
Besides running everything as admin (which worked just fine), I’ve also tested it with a regular non-admin user and it seemed to work fine as well. On that later test, I copied the entire content of the addon folder from the admin install to a folder the non-admin user had access to and then manually added the addon inside Archicad.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.